[solved] Litespeed webserver stops working while cleancache script is runnning

Discussion in 'LiteSpeed Cache' started by gnu.smtp, Apr 24, 2012.

  1. gnu.smtp

    gnu.smtp New Member

    Hello guys,

    We have a number of server with litespeed running and most of them is having issues with the cleancache script running. While running these we are not even able to do any thing on litespeed admin, not able to switch to Apache nor even able to get the sites working while running these scripts.

    Any body facing the same issue any suggestion or fix for this.

    4346 ? DN 0:00 find /tmp/lshttpd/swap/e -type f -mtime +1 -delete
    14347 ? DN 0:00 find /tmp/lshttpd/swap/e -type f -mtime +1 -delete

    We are not even able to kill these process and only thing we can do is to reboot the server to get the apache/litespeed working.

    Any idea why those are not able to get killed ? and what can be done to get this fixed for ever
    Last edited by a moderator: Jul 1, 2012
  2. webizen

    webizen New Member

    /tmp/lshttpd/swap is used by LSWS swap. you need point your cache storage to a different place (out side of /tmp/lshttpd/swap)
  3. gnu.smtp

    gnu.smtp New Member

    Hello,

    Thanks you,

    if we move this to home folder, will that be albe to get deletted if needed ? Also Where to get this done ? from litespeed admin panel ?
  4. Wirta

    Wirta New Member

    Re:

    It's interesting to note that litespeed is having issues with cleancache script. I haven't tried myself but going to give it a try and see how I can help you. I'm not an expert however I will try my best. Good luck and let me know if you're able to solve the problem.
  5. webizen

    webizen New Member

    Yes, you can point your cache storage path to somewhere under home folder such as /path/to/home/dir/diskcache. you need to manually create the folder first and point that in LSWS admin console (Configuration => Server => Cache)
  6. gnu.smtp

    gnu.smtp New Member

    Hello,

    We have changed the cache directory and swap directory to /home partition.

    But this has not helped with the issue. Also it is not possible to terminate them, once they start running.

    We cannot afford this type of frequent downtimes with a paid solution like litespeed.
  7. webizen

    webizen New Member

    You need to leave swap directory in /tmp/lshttpd unchanged and ONLY change diskcache directory to a different place (e.g. /home/diskcache). The cleancache script should only purge files under cache directory NOT others (i.e. swap, etc). Your problem is cleancache script removes files under swap as you mixed cache and swap together causing lsws inaccessible.
    Last edited: May 30, 2012
  8. gnu.smtp

    gnu.smtp New Member

    Hello,

    We had swap set to default, ad made the change when the issue persistsed even after changing cache to /home.

    The current setup is as follows.

    swap directory : /tmp/lshttpd/

    cache directory : /home/litespeed/cache

    Caching is disabled on the server. We are monitoring with this setup and will keep you posted.
  9. NiteWave

    NiteWave Administrator

    the default swap is /tmp/lshttpd/swap

    is your /tmp NFS ? it may be very slow per some of our past experience.

    if so, better to use local disk as /tmp

    also, please run iostat to check if some of hard disks have high i/o wait issue.
  10. gnu.smtp

    gnu.smtp New Member

    I have changed this to /tmp/lshttpd/swap. But we have problems with cron/script clearing swap directory also.

    all drives on the server are local.

    IO wait goes a bit high when the script/cron runs. But this affects only httpd service. Also we are unable to switch to apache when the issue occurs.

    Thank you.
  11. NiteWave

    NiteWave Administrator

    is the size of /tmp/lshttpd/swap big?

    #du -sh /tmp/lshttpd/swap
  12. gnu.smtp

    gnu.smtp New Member

    Hello,

    Another issue here is that whenever the issue occurs, and we try to check the size of directory using " du" command, the shell freeze.
  13. NiteWave

    NiteWave Administrator

    I think this is where the main problem is --- please fix it before trouble-shooting other issues. maybe hard disk has hardware problem.
  14. gnu.smtp

    gnu.smtp New Member

    Hello,

    The issue is only when we try to check the size of /tmp/lshttpd directory or its sub directories.

    "du" operation on other files and directories work fine.
  15. NiteWave

    NiteWave Administrator

    maybe bad sects under /tmp/lshttpd ?

    Please PM your server's access info, I'd investigate this strange issue.
  16. gnu.smtp

    gnu.smtp New Member

    Hello,

    Do you have a mail id where I can send the login details.

    Is it safe to PM on this forum.
  17. gnu.smtp

    gnu.smtp New Member

    Hello,

    The litespeed was froze again when the clean cache script was running. We could neither kill or restart the webserver. If you could let us know your mail id I could provide you the server details to check further.

    Thank you,
  18. NiteWave

    NiteWave Administrator

    PM is safe.
  19. gnu.smtp

    gnu.smtp New Member

    Hello,

    I have sent the server details and litespeed admin password in PM. Please check and let me know.

    Thank you,
  20. Sindre

    Sindre Member

    Please keep us updated on the outcome as I have also experienced this very same issue today with one of my servers.

Share This Page