[Solved] Multiple Versions of PHP using suexec?

Discussion in 'PHP' started by AndrewT, Jan 26, 2010.

  1. Crucial

    Crucial New Member

    This is a huge issue. We run PHP 5.2.x, 5.3.x, and 5.4.x. User's can switch between all three versions, or run them simultaneously in different directories, addon domains, or subdomains. We also run suEXEC on our servers, and the PHP extensions are setup as so:

    lsphp52 -> 5.2.x
    lsphp53 -> 5.3.x
    lsphp54 -> 5.4.x

    The only one that would actually work now is the default one (php -> lsphp5) or php53 (lsphp53).

    We either need a way to edit what extensions are suEXEC capable, or it should, by default, include the logical extensions:

    php
    php5
    php51
    php52
    php53
    php54
    php6 (which isn't even available yet, as 5.4.1 is the latest release right now)
    ...

    Please advise.
  2. AndrewT

    AndrewT Member

    Agreed. This continues to be an issue which needs some sort of permanent resolution. Ideally it would be nice if we could configure the suexec capable extensions. Otherwise at the very least we would need:

    php52
    php53
    php54

    But even then more would need to be added in a timely fashion as the version become available (php6, etc).
  3. webizen

    webizen New Member

    To clarify:

    wiki (http://www.litespeedtech.com/suppor...peed_wiki:multiple_phps_in_control_panel_lsws) statement 'suEXEC capable suffixes are: “php, php4, php5, php53, phtml, php54, fastphp” ' does NOT mean php 5.2 can not be used in suEXEC. Instead, it can be. just associate php5 handler with php 5.2. wiki is updated accordingly.

  4. cinusik

    cinusik New Member

    Is this really hard for you Litespeed guys to implement custom suExec suffixes? It could be really nice feature and more possibilities for us to have more options to provide more customized php versions to our cPanel hosting customers.
    I really like you webserver as it is a way more better than apache in every aspect.
    It will be nice if we will be able to offer for example:
    php 5.3.19 + ioncube
    php 5.3.19 without ioncube
    php 5.3.19 + GD
    php 5.3.19 without GD
    ...
    ...
    etc.

    It is not enough suExec suffixes ;) If it is not so hard to implement this I would like to see this in future litespeed versions :) It will be huge improvement for us, your customers :)

    Merry Christmas.

Share This Page