[solved] php.ini

Discussion in 'General' started by msesxi, Jul 25, 2013.

  1. msesxi

    msesxi New Member

    Hi,
    i tried this command /usr/local/lsws/fcgi-bin/lsphp5 -i | grep php.ini ,
    result: Configuration File (php.ini) Path => /usr/local/lsws/lsphp5/lib
    i checked the path but there is no php.ini !
    there is only php folder and no php.ini,

    please help
    Last edited by a moderator: Jul 25, 2013
  2. NiteWave

    NiteWave Administrator

    need create a php.ini yourself or copy php.ini from the php package

    for example, you compile lsphp-5.3.19 from lsws admin console
    /usr/local/lsws/phpbuild/php-5.3.19>ls -l php.ini*
    -rw-r--r-- 1 lsadm lsadm 69606 Nov 21 2012 php.ini-development
    -rw-r--r-- 1 lsadm lsadm 69627 Nov 21 2012 php.ini-production

    copy one of them to /usr/local/lsws/lsphp5/lib
    /usr/local/lsws/phpbuild/php-5.3.19>cp php.ini-production /usr/local/lsws/lsphp5/lib/php.ini
  3. msesxi

    msesxi New Member

    ok
    i copied by this command:
    cp /usr/local/lib/php.ini /usr/local/lsws/lsphp5/lib

    thx
  4. msesxi

    msesxi New Member

    Hi,
    cpanel shows php path Default PHP (/usr/bin/php)

    is it ok ?
  5. msesxi

    msesxi New Member

    another problem
    i have these in php.ini , but phpinfo doesnt load ioncube loader , pdomysql, ....

    extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20090626"
    zend_extension="/usr/local/IonCube/ioncube_loader_lin_5.3.so"
    extension="eaccelerator.so"
    eaccelerator.cache_dir="/tmp/eaccelerator"
    eaccelerator.check_mtime="1"
    eaccelerator.compress="1"
    eaccelerator.compress_level="9"
    eaccelerator.debug="0"
    eaccelerator.enable="1"
    eaccelerator.filter=""
    eaccelerator.optimizer="1"
    eaccelerator.shm_max="0"
    eaccelerator.shm_only="0"
    eaccelerator.shm_prune_period="0"
    eaccelerator.shm_size="16"
    eaccelerator.shm_ttl="0"
    extension="suhosin.so"
    extension = "pdo.so"
    extension = "pdo_sqlite.so"
    extension = "sqlite.so"
    extension = "pdo_mysql.so"
  6. NiteWave

    NiteWave Administrator

    need get the right php.ini first

    put a phpinfo() page under document root of a website, access it, then search "Loaded Configuration File"

Share This Page