[solved] suPHP errors

Discussion in 'Install/Configuration' started by muiruri, Nov 6, 2013.

  1. muiruri

    muiruri Member

    We have enabled suPHP on our cpanel server to enable some Wordpress plugins permissions to right to the server, as that particular cpanel account user and also to avoid having to use nobody as owner for the files and folders. This is because these plugins have lots of file actions.

    For some reason, when we switch from Apache to LS, get error down below when using the plugin.

    But when we switch back to Apache, error below disappears, therefore suPHP appears to be working fine.

    When we switch to LS, is suPHP still active?

    Or how do we maintain the same suPHP function when using LS ??

    Currently on LS setup, we have script handler as Litespeed SAPI. Also believe by default LS is using suEXEC, but wondering why the error down below shows up.

    What are we missing ??


    --------------< ERROR >-----------

    Warning: file_put_contents(/home/cpanel-user/public_html/wp-content/vimeography/cache/vimeography-gallery-1.cache) [function.file-put-contents]: failed to open stream: Permission denied in /home/cpanel-user/public_html/wp-content/plugins/vimeography/lib/cache.php on line 103

    ---------------< ERROR >-------------
    Last edited by a moderator: Nov 6, 2013
  2. NiteWave

    NiteWave Administrator

    the way to enable suPHP in litespeed:

    lsws admin console->Server->General->
    PHP suEXEC:
    PHP suEXEC Max Conn:

    what's their value set on the server ?
  3. muiruri

    muiruri Member

    Thanks! that did the trick... Was having;

    PHP suEXEC: NO
    PHP suEXEC Max Conn: 10

    Then simply changed the 1st line to; YES

    And appears to have resolved and no errors anymore.
  4. NiteWave

    NiteWave Administrator

    yes ... otherwise php will run as nobody, will cause numerous problems in a WHM/cPanel environment.

Share This Page