[solved] Switched servers - lsphp5 now running as user

Discussion in 'Install/Configuration' started by jdeg, Jan 17, 2014.

  1. jdeg

    jdeg New Member

    On my old server lsphp5 was running as nobody. On the new server it is running as the individual user for each web page.

    This is causing files that were previously set as user nobody to 403 error when trying to access them. Short of chown'ing every uploaded file in every account is there a way to just run lsphp5 as nobody?
    Last edited by a moderator: Jan 19, 2014
  2. NiteWave

    NiteWave Administrator

    yes.

    lsws web admin->Server->General->PHP suEXEC:No
  3. jdeg

    jdeg New Member

    ah, I knew I was missing a setting. Thanks!
  4. jdeg

    jdeg New Member

    I still have one user that is getting a 403 message on image files that were uploaded (wordpress). Is there something else that could cause this?
  5. NiteWave

    NiteWave Administrator

    check settings of

    lsws web admin -> Server -> Security -> File Access
    Force Strict Ownership
    Script Restricted Permission Mask
    Script Restricted Directory Permission Mask
  6. jdeg

    jdeg New Member

    Ah, I figured it out - it was actually an htaccess file that said 'deny from all' in it. Is there a setting that applies that recursively to all subfolders and files?
  7. NiteWave

    NiteWave Administrator

    yes. but rules(deny/all from all) in subfolder .htaccess can override parent folder's .htaccess

Share This Page