[solved] User Activates WooCommerce Theme in Wordpress - 503 Error

Discussion in 'General' started by craigles, Feb 12, 2013.

  1. craigles

    craigles New Member

    User Activates WooCommerce Theme in Wordpress Installation - Greeted by 503 Error

    Hi Guys,

    Hoping somebody can help me out.
    A client has approached us with an issue with their WordPress installation.

    When they go to activate a theme by WooCommerce they are greeted with a server busy 503 error message in the web browser.

    I've replicated the issue myself and can indeed confirm that it happens. On clicking activate in the themes area, it sits there for approx 5/6 seconds and then throws the 503 error.

    I enabled debugging and set to Medium level and go the following from the error_log file:

    2013-02-12 12:07:38.663 [INFO] [112.140.180.xxx:61030-0#APVH_xxx.xxxxxx.net.au] connection to [/tmp/lshttpd/APVH_xxxxx.net.au_Suphp.sock.179] on request #2, confirmed, 1, associated process: 166152, running: 1, error: Connection reset by peer!
    2013-02-12 12:07:38.664 [INFO] Remove pid: 166152, exitcode: 127

    Which really doesn't tell me an awful lot.

    Can somebody shed some light on this please?

    Thanks,
    Craig
    Last edited by a moderator: Feb 14, 2013
  2. NiteWave

    NiteWave Administrator

  3. craigles

    craigles New Member

    Hi,

    ZendGuardLoader has been disabled on this particular server, so I don't believe it's the cause of the issues.

    Can you recommend anything else?

    Thanks,
    Craig
  4. NiteWave

    NiteWave Administrator

    is it ok on apache ?

    to trouble-shooting the issue, need more info.
    for example, lsphp5 version
    #/usr/local/lsws/fcgi-bin/lsphp5 -i |head

    and lsws version, lsphp5 ext app settings.
  5. NiteWave

    NiteWave Administrator

    the issue resolved. the cause is in shared host, lsphp5 loads both php.ini:
    Loaded Configuration File /usr/local/lib/php.ini
    Additional .ini files parsed /home/user1/public_html/php.ini
    some setting in /usr/local/lib/php.ini caused 503 error.

    the way to debug/fix it, created a new lsphp53 ext app. the main difference is:
    lsphp53 --- PHPRC=$VH_ROOT/public_html
    lsphp5 --- PHP_INI_SCAN_DIR=$VH_ROOT/public_html

    in lsws admin console->Server -->Script Handler, add php53 suffix which will pick up lsphp53
    then in /home/user1/public_html/.htaccess, add this line:
    AddType application/x-httpd-php53 php53 php

    restart lsws, then check phpinfo,
    Loaded Configuration File /home/user1/public_html/php.ini
    only.

    we've updated our wiki page:
    http://www.litespeedtech.com/suppor...speed_wiki:per_user_ini_in_control_panel_lsws
    added one line:
    "This method is not recommended if you replace apache with suphp, use PHPRC is recommended"

Share This Page