[SOLVED] What is wrong with this .htaccess?

Discussion in 'Bug Reports' started by MindTooth, Apr 28, 2008.

  1. MindTooth

    MindTooth New Member

    Can you please check this?
    Code:
    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{QUERY_STRING} !.*attachment_id=.*
    RewriteCond %{HTTP_COOKIE} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]
    
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{QUERY_STRING} !.*attachment_id=.*
    RewriteCond %{HTTP_COOKIE} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    
    # END WPSuperCache
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    Birger :)
    Last edited: Apr 28, 2008
  2. anewday

    anewday Moderator

    What did you do to fix it?
  3. MindTooth

    MindTooth New Member

    I use a plugin called WP Super Cache for WordPress. If I enabled super compression, the index will consist of many strange symbols. And I found that as the problem, not the .htaccess configuration.

    Birger :)
  4. rok

    rok New Member

    My drupal Boost module have same pbl...How to solve this?When enable gzip,my inde website will have strange symbols

Share This Page