[Solved] Wordpress & Litespeed Download.gz Error

Discussion in 'General' started by ComputerChris, Jun 13, 2011.

  1. ComputerChris

    ComputerChris New Member

    I'm having a few issues with Litespeed. I have a Wordpress blog and every time I click on a post, it begins to download a "download.gz" file. I don't have any cache plugins installed and I'm not sure what could be the issue.

    These are the only warnings I have from the server log...
    Code:
    [] can't set 'Forced Type', undefined MIME Type handler/perl-script
    [] can't set 'Forced Type', undefined MIME Type handler/default-handler
    
    I also wanted to install a php accelerator and my host had installed eAccelerator and APC for me. Both were installed successfully, however they say that the integration part is not working. Is there suppose to be some special integration/configuration within Litespeed admin panel? I tried looking through the Wiki for the tutorial but the link is dead...
  2. webizen

    webizen New Member

  3. ComputerChris

    ComputerChris New Member

    What do you mean by server environment? I know that I'm running CentOs..

    Thanks for the link :)
  4. webizen

    webizen New Member

    server environment means OS (CentOS), 32bit or 64bit system, control panel if any, LSWS version, etc.

    Regarding download.gz issue, does any post or certain one trigger download.gz file?
    Last edited: Jun 13, 2011
  5. ComputerChris

    ComputerChris New Member

    CentOs 32bit
    Litespeed Web Server Enterprise v4.0.20 w/ Php 5.3.5, Suhosin , PHP Mail Header Patch
    Plesk 10.2.0

    The .gz issue happens to all posts and pages. Except the homepage..But all the images load fine.
  6. webizen

    webizen New Member

    create a simple php test page like the following and see if it causes download.
  7. ComputerChris

    ComputerChris New Member

    The php test page displays fine.
  8. webizen

    webizen New Member

    provide a sample URL in question here or in pm
  9. ComputerChris

    ComputerChris New Member

    It works now :D

    Thanks webizen!
  10. webizen

    webizen New Member

    for everyone else:

    the issue is due to WP W3 Total Cache plugin with compression turned on. response header from FF is shown as follows. iow, W3 cache plugin was _not_ disabled.

    the issue went away once cache plugin disabled. the server response header in FF is as follows:

Share This Page