suExec doesn't work for me

Discussion in 'Install/Configuration' started by Marksen, May 8, 2014.

  1. Marksen

    Marksen New Member

    I'm having troubles with setting up the Litespeed and php to run in suExec mode. I want to have php processes run as particular users instead of nobody.

    I'm running custom build php with lsapi:
    I've tried following settings which were mentioned in tutorials/wiki:
    - Configuration -> Server -> PHP suEXEC set to YES
    - php configuration in External Tab ->
    Autostart: yes
    Instances: 1
    Run on startup: suExec deamon

    - VHOST configuration:
    ExtApp Set UID Mode: DocRoot UID
    ExtApp Chroot Mode: Virtual Host Root

    PHP is spawned as root, childs as nobody:
    Could you please tell me what is wrong with my configuration?
  2. NiteWave

    NiteWave Administrator

    - Configuration -> Server -> PHP suEXEC set to YES
    this is for virtual hosts loaded from apache's httpd.conf
    if Configuration -> Server -> Load Apache Configuration set to No, all the settings under "Using Apache Configuration File" is ignored.

    >ExtApp Chroot Mode: Virtual Host Root
    how about set to "Same as Server" (default value)

    and any definition under virtual host's "Script Handler" ?
  3. Marksen

    Marksen New Member

    I didn't have any definition under Script Handler. I've added one and also added a new entry under external app where I've set up
    suExec Group and suExec User and now php processes are run by the user I've set so I guess it works :)

    There is however one little problem, I've over 25 vhosts added right now in the panel, do I have to add new external app/script handler for each of it in order to get it work? Is there any method to configure it like:
    - suexec automatically enabled for all vhosts
    - suexec username/group for each vhost is automatically set to the owner of docroot
  4. mistwang

    mistwang LiteSpeed Staff

    Are you using Apache httpd.conf configuration file to configure the vhost, or using LSWS native configuration through our WebAdmin console?

    If you use native configuration, you may look into using vhost template.

Share This Page