Swapping

Discussion in 'General' started by Giorgi, Oct 16, 2007.

  1. Giorgi

    Giorgi New Member

    Guess, I'll have to wait then :)

    but what will that update improve? I mean how are you gonna solve that?
  2. mistwang

    mistwang LiteSpeed Staff

    First, it will use tmp swap for file larger than 1MB.
    Second, we keep the part of a swap file being mapped into process memory space as small as possible to avoid exhausting the address space of a 32bit process.

    You should continue to pursue the "internal redirect" route by all means though, that's the right way to do it. :)
  3. Giorgi

    Giorgi New Member

    its no use, script is built that way and developer dont want to change it, as it works well with Apache.

    so this update will solve my large file upload/download problem? will 20gb tmp be enough? and when exactly this update is planned?

    thank you :)
  4. mistwang

    mistwang LiteSpeed Staff

    he can test the server string and make it work with both Apache and litespeed. The change is pretty simple. How is the boss there? :)

    Yes, it should solve your problem and 20gb should be enough. Maybe next week.
  5. Giorgi

    Giorgi New Member

    I have purchased this script, so I am not the boss :)

    so its not decieded yet? Ok, will wait :)

    before that, what does this error means exactly:

    Code:
    [85.118.114.19:31045-0#APVH_www.mysite.com] out of swapping space while reading request body!
  6. Giorgi

    Giorgi New Member

    Anything? Is my issue will be fixed soon? there is already new update but its only security fix :(
  7. mistwang

    mistwang LiteSpeed Staff

    Please be patient, fix to your problem is in upcoming 3.3 release. The security issue must be addressed immediately.
  8. Giorgi

    Giorgi New Member

    Of course, mistwang, thats no problem, but I dont even know when its coming, and I am really in bad situation as I am starting to loose customers, they can upload only small sized files and thats all :((

    can you tell me at least deadline for that update?
  9. mistwang

    mistwang LiteSpeed Staff

    in this week if everything goes well.
  10. mistwang

    mistwang LiteSpeed Staff

  11. Giorgi

    Giorgi New Member

  12. mistwang

    mistwang LiteSpeed Staff

    It should be addressed in the latest build.
  13. Giorgi

    Giorgi New Member

    I hope it gets realised before my license expires, because I cant afford loosing customers, I'll have to switch back to Apache (and thats last thing I want to do) and wait till new build is out :(

    really sux
  14. mistwang

    mistwang LiteSpeed Staff

    As what I have told you already. The new build with the fix is available.
    Please download http://www.litespeedtech.com/packages/3.0/lsws-3.3-ent-i386-linux.tar.gz , then do a manual upgrade by running the install.sh
  15. Giorgi

    Giorgi New Member

    Did update, nothing is corrected, same problems, could you provide quick how-to to convert back to apache, I cant waste more time and money :(

    thank you
  16. mistwang

    mistwang LiteSpeed Staff

    If you would like, PM me temp login, I can take a quick look at your configuration.
    To convert back to Apache, just stop LSWS, then start Apache, and take care of the rc script.
  17. Giorgi

    Giorgi New Member

    PM Sent! Thank you.
  18. Giorgi

    Giorgi New Member

    Problem was solved thanks to mistwang :)

    P.S. I was doing wrong package update

Share This Page