Symlink not following - 403

Discussion in 'General' started by Karl, Nov 28, 2011.

  1. Karl

    Karl New Member

    Hi,

    We've got a problem with symlinks in 4.1.8 Enterprise. It's set to follow them, yet it appears to actually be doing "If owner match".

    We have:

    /home/<user1>/folder/images

    which is a symlink to:

    /home/<user2>/folder/folder/images

    The symlink is onwed by user1, the destination folder by user2.

    With Follow Symlinks set to Yes, we get 403 errors. If we change the owner of the destination to user1 it all works fine - which is what I would expect if follow symlinks was set to "If owner match".

    Thanks,

    Karl
  2. webizen

    webizen New Member

    what are your other settings for File access such as Required Permission Mask, Restricted Permission Mask, etc?
  3. Karl

    Karl New Member

    Hi,

    Both the default 000. All other files etc. are served fine, no issues.

    Thanks,
  4. webizen

    webizen New Member

    are you on cPanel? can you enable debug logging and see if anything tells why access is denied?
  5. Karl

    Karl New Member

    Hi,

    This is a stand alone install, no cPanel. It is using Apache configs (customer was migrated from an Apache box), Options +FollowSymLinks is there though.

    Will turn up the debug logging when I can reload LSWS (it's a v. v. busy server).

    Thanks,
  6. Karl

    Karl New Member

    Code:
    Found symbolic link, or owner of symbolic link and link target does not match for path
    
    Code:
    File Access
    Follow Symbolic Link	Yes
    Check Symbolic Link	No
    Required Permission Mask	000
    Restricted Permission Mask	 000
    
  7. mistwang

    mistwang LiteSpeed Staff

    Where you put "Options +FollowSymLinks"? If it is in .htaccess, you need to check if "AllowOverride" is set properly. Looks like it was ignored, the default is "SymlinksIfOwnerMatch". Add that to the <VirtualHost...> section should work.
  8. Karl

    Karl New Member

    Hi,

    The: Options +FollowSymLinks is in the <VirtualHost> for each vhost :/

    Thanks,
  9. webizen

    webizen New Member

    pm the temporary server access if you would like us to look at further.

Share This Page