Too EAProc WaitQ

Discussion in 'General' started by Prince, Mar 21, 2011.

  1. Prince

    Prince New Member

    Gentlemen i'm still yet to know what's causing so many EAProc WaitQ in my lightspeed which cause server load and slow loading sites. 20k unique visitors daily.

    I have 2 dedicated servers 1 for webpages, 2 for db

    Webpages server 1
    1. AMD Quad x 8 CORES 2.0Ghz Opteron 6128
    2. 24GB DDR3 SDRAM
    3. 2 x SAS RAID 1 (15,000 rpm)

    db server 2
    1. AMD Quad x 8 CORES 2.0Ghz Opteron 6128
    2. 16GB DDR3 SDRAM
    3. 2 x SAS RAID 1 (15,000 rpm)


    mysql configuration
    datadir=/home/mysql
    tmpdir=/home/mysqltmp
    skip-locking
    safe-show-database
    old_passwords=1
    ;long_query_time=2
    ;log-slow-queries=/var/log/mysql-slow-queries.log
    ;skip-name-resolve
    query_cache_limit=1M
    query_cache_size=128M
    query_cache_type=1
    max_user_connections=100
    max_connections=100
    thread_cache_size=6M
    table_cache=27500
    key_buffer=1700M
    max_connect_errors=20
    max_allowed_packet=128M
    join_buffer_size=48M
    record_buffer=1M
    sort_buffer_size=8M
    read_buffer_size=8M
    read_rnd_buffer_size=8M
    thread_concurrency=16
    myisam_sort_buffer_size=64M
    local-infile=0
    concurrent_insert=2
    innodb_file_per_table
    innodb_flush_method=O_DIRECT
    innodb_buffer_pool_size=3G
    innodb_additional_mem_pool_size=100M
    innodb_log_file_size = 10M
    tmp_table_size = 256M
    max_heap_table_size = 256M
    wait_timeout = 120
    connect_timeout = 10
    interactive_timeout = 1200

    myisam-recover=BACKUP,FORCE

    [mysqldump]
    quick
    max_allowed_packet = 16M

    [mysql]
    no-auto-rehash

    [isamchk]
    key_buffer = 128M
    sort_buffer_size = 128M
    read_buffer = 2M
    write_buffer = 2M

    [myisamchk]
    key_buffer = 128M
    sort_buffer_size = 128M
    read_buffer = 2M
    write_buffer = 2M


    Please also tell me what is eating up my memory in my server 1 for webpages.

    Click on the link below for screenshots, to tell me the right values.

    [​IMG]

    [​IMG]

    [​IMG]

    Thanks.

    Attached Files:

    Last edited: Mar 21, 2011
  2. Prince

    Prince New Member

    My host LiquidWeb can't help because they don't support lightspeed.
  3. webizen

    webizen New Member

    the screenshots are too small. pls send.

    also i am assuming it is the peak time that you have many EAProc WaitQ, correct?
  4. Prince

    Prince New Member

    That's correct.

    I don't know how to make the screenshot bigger.

    Maybe you give your email, i send it to you.
    Last edited: Mar 21, 2011
  5. webizen

    webizen New Member

    You can upload to site like http://tinypic.com/ which would not shrink the size and send us the URL.
  6. Prince

    Prince New Member

    I have update the screenshot.
  7. webizen

    webizen New Member

    instances in lsphp5 should be set to 1.

    also run 'top' from command line on your DB server during the peak time (when you have many EAProc WaitQ) and paste your screenshot here.
  8. Prince

    Prince New Member

    I have changed instances to 1.

    Please give more details on how to run it as i'm a server novice.

    Thanks.
  9. webizen

    webizen New Member

    To run it from command line, you need to open a terminal session and issue following command to log into your server:
    You can also use ssh client program such as Putty (free), SecureCRT to initiate an ssh session.

    Once login, issue 'top' at the OS prompt.
  10. webizen

    webizen New Member

    also increase the following settings to something bigger than 200 (max connections of lsphp5) in mysql config:
  11. Prince

    Prince New Member

    I have increase to 250 each, i will wait tomorrow to see how my site perform, but my host was againt it. Read his comment below...

    "As I've stated before, this is not a good idea, you will most likely just
    overrun your box with mysql connections. The reason things are running slow
    has nothing to do with the # of connections allowed but the time at which it
    takes to execute them. I can tell this to litespeed as well if you like.

    Regards,
    Chris"
  12. webizen

    webizen New Member

    What application are you running on the web server?
  13. Prince

    Prince New Member

    Wordpress, SMF forum and a social network.
  14. Prince

    Prince New Member

    I solved the the problem by increasing innodb_buffer_pool_size=3G to 6G and max_user_connections=100
    max_connections=100 to 300 each.

    Now sites running faster, but i have to upgrade ram in my host server.
  15. webizen

    webizen New Member

    Thanks for the update.

    Do you have any cache enabled at your application level (such as Wordpress, SMF)?
  16. eva2000

    eva2000 Member

    Prince, I use litespeed vps edition on my wordpress blog as well definitely install wordpress plugin w3 total cache, of course with litespeed in use you can disable w3 total cache's options for http gzip file compression in browser cache.

    Any reason you set the small file and mmap cache sizes to such a small value as 300 bytes ?

    Total Small File Cache Size (bytes)
    Total MMAP Cache Size (bytes)

    IIRC default is round 20MB (20M) or 40MB (40M)
  17. Prince

    Prince New Member

    YES,
    For wordpress i use "quick cache" for SMF i use memcache.
  18. Prince

    Prince New Member

    No reason, i just put in those values randomly.

    What values should be there?

Share This Page