Unable to create Rails EasyHost Template

Discussion in 'General' started by djsodom, Dec 31, 2006.

  1. djsodom

    djsodom New Member

    When I create a virtual host using the Rails Template and then restart, I get this warning:
    [config:server:vhosts] missing <virtualHostList>

    And if I instantiate it, and then try to view it, I get this error:
    /opt/lsws/conf/quizical.xml is not a valid file.

    these notices show up in my log too:

    2006-12-31 14:46:44.602 NOTICE [66.90.167.160:55903-0#_AdminVHost] [STDERR] PHP Warning: array_keys() [<a href='function.array-keys'>function.array-keys</a>]: The first argument should be an array in /opt/lsws/admin/html.3.0RC1/classes/ConfCenter.php on line 67
    2006-12-31 14:46:44.602 NOTICE [66.90.167.160:55903-0#_AdminVHost] [STDERR] PHP Warning: Invalid argument supplied for foreach() in /opt/lsws/admin/html.3.0RC1/classes/Service.php on line 72
    2006-12-31 14:46:44.602 NOTICE [66.90.167.160:55903-0#_AdminVHost] [STDERR] PHP Warning: array_keys() [<a href='function.array-keys'>function.array-keys</a>]: The first argument should be an array in /opt/lsws/admin/html.3.0RC1/classes/ConfCenter.php on line 67
    2006-12-31 14:46:44.602 NOTICE [66.90.167.160:55903-0#_AdminVHost] [STDERR] PHP Warning: Invalid argument supplied for foreach() in /opt/lsws/admin/html.3.0RC1/classes/Service.php on line 72
    2006-12-31 14:46:51.327 NOTICE [66.90.167.160:55904-0#_AdminVHost] [STDERR] PHP Warning: array_keys() [<a href='function.array-keys'>function.array-keys</a>]: The first argument should be an array in /opt/lsws/admin/html.3.0RC1/classes/ConfCenter.php on line 67
    2006-12-31 14:46:51.328 NOTICE [66.90.167.160:55904-0#_AdminVHost] [STDERR] PHP Warning: Invalid argument supplied for foreach() in /opt/lsws/admin/html.3.0RC1/classes/Service.php on line 72
    2006-12-31 14:47:58.068 NOTICE [66.90.167.160:55906-8#_AdminVHost] [STDERR] /opt/lsws/conf/quizical.xml is not a valid file.
    2006-12-31 14:50:04.169 NOTICE [66.90.167.160:55922-1#_AdminVHost] [STDERR] /opt/lsws/conf/quizical.xml is not a valid file.

    the /opt.lsws/conf/ directory exists and is owned by the same user as is running lsws.

    any thoughts?
  2. mistwang

    mistwang LiteSpeed Staff

    looks like a bug in the new admin interface, we will check.
  3. phallstrom

    phallstrom New Member

    I have the same problem. Creating a virtual host in the easyrailstemplate works fine. Instantiating it results in it complaining that the xml config file is invalid...

    this is on freebsd6, 3.0RC1.
    Last edited: Jan 17, 2007
  4. mistwang

    mistwang LiteSpeed Staff

    This should have been addressed in our upcoming 3.0RC2 release.

Share This Page