unexpectly shutdown

Discussion in 'General' started by pardis, Mar 8, 2012.

  1. pardis

    pardis New Member

    Hello :

    from last 12 hrs ago (till now) all my LS server shutdown unexpectly , and not back again with restart , SO I was switch to Apache and again switch to LS until work again. also I didn't see any abnormal detail in LS logs.
    help me please.

    Thank you
    Best regards
  2. mistwang

    mistwang LiteSpeed Staff

  3. pardis

    pardis New Member

    No , I checked it .
  4. mistwang

    mistwang LiteSpeed Staff

    Then, you need to check if "litespeed" process is actually running with "ps". and check error log for any hint why it stops.

    Another possibility is some anti-hacking script killed litespeed processes as they do not know litespeed replaces Apache.

    Recall any change you have made to the server, and revert back one by one if you can until you find the cause.
  5. mistwang

    mistwang LiteSpeed Staff

    Or, you forgot to renew your monthly license?
  6. pardis

    pardis New Member

    yesterday i was renew it.
    my LS version is 4.1.10
  7. webizen

    webizen New Member

    do this from command line and paste result here.

  8. mistwang

    mistwang LiteSpeed Staff

    Please check if any core file under /tmp/lshttpd and /tmp/lshttpd/bak_core .
    send us the log file.
    Upgrade to the latest 4.2.1 build with

    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.1

    if it does not help, send us a temp root access, we will investigate on your server if you want.

Share This Page