updgrade to php5 problem

Discussion in 'Install/Configuration' started by karloff, Jul 16, 2008.

  1. karloff

    karloff New Member

    when trying to upgrade to php5 via CP is seem to get the following error.

    Code:
    ........
    
    checking for xml2-config path... /usr/bin/xml2-config
    checking whether libxml build works... yes
    checking for OpenSSL support... no
    checking for Kerberos support... no
    checking for PCRE support... yes
    checking for ZLIB support... yes
    checking if the location of ZLIB install directory is defined... no
    checking for gzgets in -lz... yes
    checking whether to enable bc style precision math functions... no
    checking for BZip2 support... no
    checking whether to enable calendar conversion support... no
    checking whether to enable ctype functions... yes
    checking for cURL support... no
    checking if we should use cURL for url streams... no
    checking for long... (cached) yes
    checking size of long... (cached) 8
    checking for int... (cached) yes
    checking size of int... (cached) 4
    checking for int32_t... yes
    checking for uint32_t... yes
    checking for sys/types.h... (cached) yes
    checking for inttypes.h... (cached) yes
    checking for stdint.h... (cached) yes
    checking for string.h... (cached) yes
    checking for stdlib.h... (cached) yes
    checking for strtoll... yes
    checking for atoll... yes
    checking for strftime... (cached) yes
    checking for QDBM support... no
    checking for GDBM support... no
    checking for NDBM support... no
    checking for Berkeley DB4 support... no
    checking for Berkeley DB3 support... no
    checking for Berkeley DB2 support... no
    checking for DB1 support... no
    checking for DBM support... no
    checking for CDB support... no
    checking for INI File support... no
    checking for FlatFile support... no
    checking whether to enable DBA interface... no
    checking whether to enable dbase support... no
    checking whether to enable DOM support... yes
    checking for xml2-config path... (cached) /usr/bin/xml2-config
    checking whether libxml build works... (cached) yes
    checking whether to enable EXIF (metadata from images) support... no
    checking for FrontBase SQL92 (fbsql) support... no
    checking for FDF support... no
    checking whether to enable input filter support... yes
    checking pcre install prefix... no
    checking whether to enable FTP support... no
    checking OpenSSL dir for FTP... no
    checking for GD support... yes
    checking for the location of libjpeg... no
    checking for the location of libpng... no
    checking for the location of libXpm... no
    checking for FreeType 1.x support... no
    checking for FreeType 2... no
    checking for T1lib support... no
    checking whether to enable truetype string function in GD... no
    checking whether to enable JIS-mapped Japanese font support in GD... no
    checking for fabsf... yes
    checking for floorf... yes
    If configure fails try --with-jpeg-dir=
    configure: error: libpng.(a|so) not found. 
    i have install the following rpm's

    yum install libxml2 libxml2-devel

    but can't get any further, any ideas
    Last edited: Jul 16, 2008
  2. karloff

    karloff New Member

  3. mistwang

    mistwang LiteSpeed Staff

    You need to install libpng-devel and libjpeg-devel
  4. karloff

    karloff New Member

    i have managed to install php5, however when i check the verion i get

    fcgi-bin/lsphp -v
    PHP 4.4.8 (litespeed) (built: Jan 8 2008 14:37:45)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies


    why would that be? do i need to reconfigure anything, or must i reboot the entire server?



    edit: i tried to restart my server and still get the old version showing, also my sql has stop.. typical;)
    Last edited: Jul 16, 2008
  5. mistwang

    mistwang LiteSpeed Staff

    change "php" "Script Handler" configuration at server level from lsphp4 to lsphp5.
  6. karloff

    karloff New Member

    do i need to edit the current script handlers or create a new one? i can't see and option for that?
  7. mistwang

    mistwang LiteSpeed Staff

    http://www.litespeedtech.com/docs/webserver/config/scripthandler/

    Under "Server"->"Script Handler" tab, you should have a script handler configuration for "php". the "Handler Name" should be lsphp4 or phpLsapi, try to change it to "lsphp5", if it does not show up in the drop down list, you need to create a "lsphp5" External app under "External App" tab using the lsphp5 binary you have built.
    Just use the existing external app configuration as an example.
  8. karloff

    karloff New Member

    i have done that but the php version does not seem to have changed
  9. mistwang

    mistwang LiteSpeed Staff

    run "/opt/lsws/fcgi-bin/lsphp5 -i" from command line see if it is really PHP5.

    Make sure to restart the server after the configuration change.
  10. karloff

    karloff New Member

    i have restarted the server and web serrver, however i still get the smae message.

    if i run

    /usr/local/lsws/fcgi-bin/lsphp5 -v


    i get the correct version.

    do i need to remove the lsphp file and rename the lsphp5 file as lsphp?
  11. mistwang

    mistwang LiteSpeed Staff

    You need to change the external app "command" configuration to use "$SERVER_ROOT/fcgi-bin/lsphp5" instead of changing the file name.

    And it is even better to create a "lsphp5" external app instead of changing the existing one for PHP4.
  12. karloff

    karloff New Member

    i did that, however i seem to get the error

    I have notice that in my tmp/lshttpd directory my sock files are not named as they are supposed to

    eg is set the address for the VH to uds://tmp/lshttpd/$VH_NAME_lsphp.sock

    but in the tmp/lshttpd dir they are called

    uds://tmp/lshttpd/$VH_NAME_.sock

    obviously causing some conflicting, how can i resolve this. without totally removing the vh and recreating them?
    Last edited: Jul 19, 2008
  13. mistwang

    mistwang LiteSpeed Staff

    Please try 3.3.16 package, just change the version number in the download link.
  14. karloff

    karloff New Member

    i have just tried a re-install of php5 and i get this warning message
    however is seem to install fine other than that

    will keep you posted if it works, otherwise i will try the upgrade
    Last edited: Jul 21, 2008
  15. karloff

    karloff New Member

    unfortunetly i could not get it working, still giving me a 503 error on php5. who should be the owner of fcgi-bin dir and its contents? root or nobody? tried changing it but no success:(

    the only error i get is this
    nothing in any other logs. mistwang, how do i go about changing the version?
  16. mistwang

    mistwang LiteSpeed Staff

    PM me a temp root login of your server, I can take a look.
  17. mistwang

    mistwang LiteSpeed Staff

    The main problem is that "Auto Start" was not set for "lsphp5" app at server level.
    And you also have virtual host level configurations in the mix, since all of your vhosts are owned by "nobody" user, PHP suEXEC does not give any extra benefits, so I removed the vhost level "script handler" configuration.
  18. karloff

    karloff New Member

    thanks man, it seems to have updated my php, however there seems to be a problem with my main site, it doesn't seem to show anything. just a blank screen?

    edit: i should not there is nothing in the error.log that would describe the problem as well
    Last edited: Jul 21, 2008
  19. karloff

    karloff New Member

    infact i'm getting the error

    [ADMIN] authentication failed!
  20. wagonlips

    wagonlips New Member

    Version 3.3.17 installed on OS X 10.5 PPC
    Getting same error when trying to upgrade to PHP 5 using the control panel:
    Code:
    configure: error: libpng.(a|so) not found.
    /opt/local/lib/libpng.a <--is there. Is there a way to make Litespeed see it?

    (Also tried 3.3.16, same problem)
    Last edited: Aug 28, 2008

Share This Page