Upgrade Killed LiteSpeed & Apache

Discussion in 'Install/Configuration' started by edigest, Mar 18, 2013.

  1. edigest

    edigest New Member

    Re this thread: http://www.litespeedtech.com/support/forum/showthread.php?t=6746

    I could not update LiteSpeed which was giving me a license version error. So I opted to upgrade to a 2-CPU license to solve the license version error and check out caching. I requested and received a trial license.

    I changed my LiteSpeed license via the CPanel GUI and it would not accept it. The error message said to upgrade manually, which I did.

    The manual upgrade failed (I did not copy the error message) and LiteSpeed would not restart.

    At this point everything LiteSpeed is dead, including the LiteSpeed admin.

    Any ideas?
  2. NiteWave

    NiteWave Administrator

  3. edigest

    edigest New Member

    It shows:

    [OK] Your trial license key will expire in 6 days!
    2013-03-18 05:24:36.625 [NOTICE] Memory size is: 4194304KB.

    In the CPanel LiteSpeed plugin it now shows 4.2.2 (the problem that started this all is that LiteSpeed would not upgrade with a version error) and the license management shows:

    Current License: TRIAL

    I'm not sure why it broke before, but I switched to LiteSpeed and it is running now.

    Last Question: If I decide to switch to the UltraVPS version, can I switch the license in the CPanel app or do I need to run install.sh?
  4. NiteWave

    NiteWave Administrator

    no need. any license change, at command line, you just need run
    /usr/local/lsws/bin/lshttpd -r

    in cPanel app change the license should work too --- follow by a lsws restart.

Share This Page