Upgrade with problems in ruby rails warn.

Discussion in 'Install/Configuration' started by guy100, Jan 1, 2013.

  1. guy100

    guy100 New Member

    I have in 2 servers Litespeed. I deside to upgrade from V 4.1.13 to 4.2.1 and from that time i had 2 problems.
    in new version i continues having error
    WARN [config:server:rails] Cannot find ruby interpreter, Rails easy configuration is turned off
    and also in csf i receive all time error with

    Code:
    > Subject: lfd on server.x.x: Suspicious process running under user nobody
    >
    > Time:    Tue Jan  1 20:06:33 2013 +0200
    > PID:     22125
    > Account: nobody
    > Uptime:  3686 seconds
    >
    >
    > Executable:
    >
    > /usr/local/lsws/bin/lshttpd.4.2.1
    >
    >
    > Command Line (often faked in exploits):
    >
    > litespeed (lshttpd)
    >
    >
    > Network connections by the process (if any):
    >
    > tcp: 127.0.0.1:443 -> 0.0.0.0:0
    > tcp: 127.0.0.1:80 -> 0.0.0.0:0
    > tcp: x:443 -> 0.0.0.0:0
    > tcp:x:80 -> 0.0.0.0:0
    > tcp: x:443 -> 0.0.0.0:0
    > tcpx:80 -> 0.0.0.0:0
    > tcp: x:443 -> 0.0.0.0:0
    > tcp: x:80 -> 0.0.0.0:0
    > tcp: 0.0.0.0:7080 -> 0.0.0.0:0
    >
    >
    > Files open by the process (if any):
    >
    > /dev/null
    > /dev/null
    > /dev/urandom
    > anon_inode:[eventpoll]
    > /usr/local/lsws/logs/access.log
    > /usr/local/apache/logs/stderr.log
    I have downgrade one and in this all back in normal.

    How can i disable Ruby (i dont want to installed it ) and not have anymore this 2 errors?
  2. NiteWave

    NiteWave Administrator

    tested in my testing box, edit /usr/local/lsws/conf/httpd_config.xml, delete
    <railsDefaults>
    ...
    </railsDefaults>
    the warning disappears.

    for csf/lfd warning, the warning is wrong, it's normal lshttpd process, should include it in white list to prevent further warnings.

Share This Page