Upgrate to 4.0.13 download failed

Discussion in 'Install/Configuration' started by yak983, Feb 23, 2010.

  1. yak983

    yak983 New Member

    then i try to upgrate from .12 to .13 in the admin panel i receved the follow message

    Error: Failed to download release 4.0.13!

    the server are not firewalled to outgoing port
  2. ltd82

    ltd82 New Member

    same here.
  3. yak983

    yak983 New Member

    good :D anyone can help us?
  4. NiteWave

    NiteWave Administrator

    is manual update working?

    steps:
    ssh to /path/to/lsws/autoupdate
    wget 4.0.13...tar.gz
    tar zxvf 4.0.13...tar.gz
    cd 4.0.13
    ./install.sh

    please try this if update is urgent for you.
  5. yak983

    yak983 New Member

    manual upgrade work !
  6. garnser

    garnser New Member

    I'm experiencing the same issue, is there any ETA on a fix?

    Error-log:
    2010-02-23 11:04:22.337 [NOTICE] [10.254.254.254:62262-0#_AdminVHost] [STDERR] PHP Warning: is_file() [<a href='function.is-file'>function.is-file</a>]: Stat failed for /usr/local/lsws/conf/httpd_config.xml (errno=13 - Permission denied) in /usr/local/lsws/admin/html.4.0.12/classes/XmlTreeBuilder.php on line 13
    2010-02-23 11:04:22.337 [NOTICE] [10.254.254.254:62262-0#_AdminVHost] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-02-23 11:04:22.890 [NOTICE] [10.254.254.254:62262-1#_AdminVHost:lsapi] [STDERR] PHP Warning: is_file() [<a href='function.is-file'>function.is-file</a>]: Stat failed for /usr/local/lsws/conf/httpd_config.xml (errno=13 - Permission denied) in /usr/local/lsws/admin/html.4.0.12/classes/XmlTreeBuilder.php on line 13
    2010-02-23 11:04:22.890 [NOTICE] [10.254.254.254:62262-1#_AdminVHost:lsapi] [STDERR] /usr/local/lsws/conf/httpd_config.xml is not a valid file.
    2010-02-23 11:04:22.895 [NOTICE] [10.254.254.254:62262-1#_AdminVHost:lsapi] [STDERR] PHP Warning: file_get_contents() [<a href='function.file-get-contents'>function.file-get-contents</a>]: URL file-access is disabled in the server configuration in /usr/local/lsws/admin/html.4.0.12/classes/ws/Service.php on line 534
    2010-02-23 11:04:22.895 [NOTICE] [10.254.254.254:62262-1#_AdminVHost:lsapi] [STDERR] PHP Warning: file_get_contents(http://download.litespeedtech.com/packages/latest/lsws-4.0.13-ent-x86_64-linux.tar.gz) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: no suitable wrapper could be found in /usr/local/lsws/admin/html.4.0.12/classes/ws/Service.php on line 534
  7. kule

    kule New Member

    Thanks NiteWave thats just what I was looking for - any chance of adding these instructions to the upgrade part of the install/upgrade docs? (http://litespeedtech.com/docs/webserver/install/)
  8. mistwang

    mistwang LiteSpeed Staff

    You can change /path/to/lsws/admin/conf/php.ini
    locate "allow_url_fopen"
    and change it to

    "allow_url_fopen = On"

    This has been addressed in 4.0.13 .

Share This Page