User not creating session or cache files.

Discussion in 'PHP' started by felosi, Jun 16, 2009.

  1. felosi

    felosi New Member

    Well I am totally baffled by this one and have never had this problem before. I dont know if it is litespeed or what. But anyway, I got this client's server, it used to be on a cluster, now its just litespeed. I installed php and everything just like I normally would any other server but I now have the strangest problem.

    I noticed that the user was not creating session files in /tmp nor would create any cache files in eaccelerator's cache directory.

    AT first I got an shmget error doing php -v but adjusting some things in sysctl.conf remedied that. I have recompiled php over and over with different configure options and still end up at same place.

    When you do php -v as root you get

    PHP 5.2.9 (cli) (built: Jun 14 2009 11:23:06)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
    with eAccelerator v0.9.5.3, Copyright (c) 2004-2006 eAccelerator, by eAccelerator
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies

    Plus it will create session and cache files for root

    When you su to the user and do php -v you get

    PHP 5.2.9 (cli) (built: Jun 14 2009 11:23:06)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

    Creates no cache or session files.

    As far as the system it is a centos 5 i386, using default kernel, selinux is disabled and all that. ALl file permissions are correct. No open base dir is set. Everything looks normal

    Php was configured with this

    Code:
    ./configure'  '--prefix=/usr/local' '--with-litespeed' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstring' '--enable-pdo=shared' '--enable-sockets' '--enable-zip' '--with-bz2' '--with-curl=/opt/curlssl/' '--with-curlwrappers' '--with-gd' '--with-gettext' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libexpat-dir=/usr' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mhash=/opt/mhash/' '--with-mime-magic' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-png-dir=/usr' '--with-sqlite=shared' '--with-xmlrpc' '--with-xpm-dir=/usr' '--with-zlib' '--with-zlib-dir=/usr' '--with-config-file-path=/opt/lsws/conf'

    The php info page is at
    http://carigold.com/info.php


    Any idea whats going on here?
  2. auser

    auser Super Moderator

    maybe php.ini different under root and user?

    to check:
    cd $SERVER_ROOT/fcgi-bin
    ./lsphp-5.2.9 -i|grep "php.ini"

    under root and user respectively.

Share This Page