Version 2.2.2 broken on Solaris for Sparc

Discussion in 'Install/Configuration' started by jcordero, Oct 1, 2006.

  1. jcordero

    jcordero New Member

    I have version 2.2.1 running without problems. (I had a little problem initially with libjpeg but I solved with a simple link to the library so the executable can find it).

    After a while I try the new version 2.2.2 but it fails at startup with

    bash-2.05# ./lswsctrl start
    ./lshttpd: syntax error at line 1: `(' unexpected
    [ERROR] Failed to start lshttpd!

    The most stupid thing is that I have deleted the old version files... Now I have no http service to run. There is a link to the old version 2.2.1 ?

    Any help welcome!
  2. mistwang

    mistwang LiteSpeed Staff

    You should be able to switch back to older release with lsws/admin/misc/mgr_ver.sh 2.2.1,
    if it does not work, just replace "2.2.2" with "2.2.1" in our download link to get the older package.
  3. jcordero

    jcordero New Member

    Thank you

    Thank for the promptly answer!

    I downloaded the 2.2.1 version that works fine.
    Its a great product. I love the administration interface.

    If anyone needs a LSAPI module for PHP 5.1.4 for Solaris Sparc send me a PM and i sent you back the working module.

Share This Page