Virtual hosts

Discussion in 'Install/Configuration' started by tonyedgecombe, Nov 2, 2009.

  1. tonyedgecombe

    tonyedgecombe New Member

    I have three virtual hosts I copied from my apache configuration, unfortunately litespeed only seems to accept the last one.

    Each looks like this:

    <VirtualHost *>
    ServerAdmin webmaster@localhost

    ServerName www.domain.com
    ServerAlias domain.com

    DocumentRoot /web/domain/

    <Directory /web/domain/>
    Options FollowSymLinks MultiViews
    AllowOverride All
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    ServerSignature Off

    </VirtualHost>

    Admin just shows the last one host running and every request shows that domain.
  2. mistwang

    mistwang LiteSpeed Staff

    Please try changing <VirtualHost *> to <VritulHost xx.xx.xx.xx:80>
    see if it help or not.
  3. tonyedgecombe

    tonyedgecombe New Member

    Thanks, that resolved the problem.

Share This Page