Web Server reporting apache?

Discussion in 'Apache Migration/Compatibility' started by 04nunhucks, Sep 3, 2009.

  1. 04nunhucks

    04nunhucks New Member

    Hello, I've installed LiteSpeed on my server, and have switched to it, however, the server reports that Apache is the web server, that's service the requests.

    This is said in both headers and error pages.

    Please help resolve.

    Thanks
  2. anewday

    anewday Moderator

    Maybe you didn't change port offset to 0 then restart Litespeed. You have to stop Apache first.
  3. 04nunhucks

    04nunhucks New Member

    Nope, port offset is definately 0, LS says: LiteSpeed is running (PID = 26331). Apache is not running.
  4. anewday

    anewday Moderator

    What's the output of:

    ps ef |grep httpd

    Is the Litespeed real-time status page showing any requests? Do you have mod_security enabled?
    Last edited: Sep 3, 2009
  5. 04nunhucks

    04nunhucks New Member

    ps ef |grep httpd
    18027 pts/1 S+ 0:00 \_ grep httpd MANPATH=/usr/lib/courier-imap/man: HOSTNAME=server.radonsystems.net TERM=xterm SHELL=/bin/bash HISTSIZE=1000 SSH_CLIENT=::ffff:78.149.199.134 60668 22 SSH_TTY=/dev/pts/1 USER=root LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:eek:r=40;31;01:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.ogg=01;35:*.mp3=01;35:*.wav=01;35: MAIL=/var/spool/mail/root PATH=/usr/local/jdk/bin:/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib/courier-imap/sbin:/usr/lib/courier-imap/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/usr/X11R6/bin:/root/bin INPUTRC=/etc/inputrc PWD=/root JAVA_HOME=/usr/local/jdk EDITOR=pico LANG=en_US.UTF-8 SHLVL=1 HOME=/root LS_OPTIONS=--color=tty -F -a -b -T 0 LOGNAME=root VISUAL=pico CLASSPATH=.:/usr/local/jdk/lib/classes.zip SSH_CONNECTION=::ffff:78.149.199.134 60668 ::ffff:74.50.118.155 22 LESSOPEN=|/usr/bin/lesspipe.sh %s G_BROKEN_FILENAMES=1 _=/bin/grep

    Nope, no mod_security.

    0 requests being shown.

    Installed via cPanel rememeber.
    Last edited: Sep 3, 2009
  6. anewday

    anewday Moderator

    Apache must be running in order to service those requests. Maybe you didn't stop it properly. How did you do it?
  7. 04nunhucks

    04nunhucks New Member

    I used the cPanel plugin to set lsws as the web server.
  8. anewday

    anewday Moderator

    I meant how did you stop apache?
  9. 04nunhucks

    04nunhucks New Member

    The litespeed cPanel Plugin: Switch to LiteSpeed.
  10. anyoneyoubet

    anyoneyoubet New Member

    better late than never

    Apache/2.2.13 (Unix) mod_ssl/2.2.13 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at www.radonsystems.net Port 80

    yup still reports Apache, I also see that you are trying to set up a forum software package.
    Maybe the lightspeed was installed as a plugin and did not replace Apache.
    just a thought...
    this was a 404 page and can say anything you like in the reporting of the server software.

    this information is in a file in the httpd-info.conf
    in apache
    #ExtendedStatus On

    #
    # Allow remote server configuration reports, with the URL of
    # http://servername/server-info (requires that mod_info.c be loaded).
    # Change the ".localhost" to match your domain to enable.
    #
    <Location /server-info>
    SetHandler server-info
    Order deny,allow
    Deny from all
    Allow from .localhost
    </Location>


    so if you want it to say you are running lightspeed say soin the file.

Share This Page