/webmail giving a 500 Error

Discussion in 'General' started by optize, Mar 2, 2013.

  1. optize

    optize New Member

    cPanel has an alias /webmail which goes to:

    ScriptAliasMatch ^/?webmail/?$ /usr/local/cpanel/cgi-sys/wredirect.cgi

    That script seems to work:

    root@cpanel [/etc/httpd]# /usr/local/cpanel/cgi-sys/wredirect.cgi
    Status: 301
    Location: https://cpanel.server.com:2096

    However, when clients go to it (all domains) they get a 500 internal server error.

    I've turned on debugging and this is what it spit out:

    ----


    2013-03-02 07:36:46.731 [NOTICE] [my.ip:54851-0#APVH_domain.com] Content len: 0, Request line: 'GET /webmail HTTP/1.1'
    2013-03-02 07:36:46.731 [INFO] [my.ip:54851-0#APVH_domain.com] Cookie len: 101, wordpress_logged_in_cef<cookie values>
    2013-03-02 07:36:46.731 [DEBUG] [my.ip:54851-0#APVH_domain.com] Check Symbolic link for [/usr/local/cpanel/cgi-sys/wredirect.cgi] is successful, access to target [/usr/local/cpanel/cgi-sys/wredirect.cgi] is granted
    2013-03-02 07:36:46.731 [DEBUG] [my.ip:54851-0#APVH_domain.com] processContextPath() return 0
    2013-03-02 07:36:46.731 [DEBUG] [my.ip:54851-0#APVH_domain.com] ScanPost: 0
    2013-03-02 07:36:46.731 [DEBUG] [my.ip:54851-0#APVH_domain.com] run cgi processor.
    2013-03-02 07:36:46.731 [DEBUG] [uds://usr/local/lsws/admin/cgid/cgid.sock.141] request [my.ip:54851-0#APVH_domain.com:cgi] is assigned with connection [0x141515c0]!
    2013-03-02 07:36:46.731 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] MOD: 2, UID: 1031, GID: 1024
    2013-03-02 07:36:46.731 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] [ExtConn] reconnect()
    2013-03-02 07:36:46.732 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] [ExtConn] connecting to [uds://usr/local/lsws/admin/cgid/cgid.sock.141]...
    2013-03-02 07:36:46.732 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] ExtConn::eek:nWrite()
    2013-03-02 07:36:46.732 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] CgidConn::eek:nWrite()
    2013-03-02 07:36:46.732 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] request header is done
    2013-03-02 07:36:46.732 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] ExtConn::continueRead()
    2013-03-02 07:36:46.732 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] Request body done!
    2013-03-02 07:36:46.732 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] ExtConn::suspendWrite()
    2013-03-02 07:36:46.732 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] ExtConn::suspendWrite()
    2013-03-02 07:36:46.732 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] processNewReq() return 0.
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] ExtConn::eek:nRead(), state: 2
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] CgidConn::eek:nRead()
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] [EXT] EndResponse( endCode=0, protocolStatus=0 )
    2013-03-02 07:36:46.740 [NOTICE] [my.ip:54851-0#APVH_domain.com:cgi] Premature end of response header.
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] HttpIOLink::continueWrite()...
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] write resumed!
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] ExtConn::eek:nEventDone(), fd: 240, state: 2, event: 17, revents: 16.
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] HttpIOLink::handleEvents() events=4!
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] HttpIOLink::suspendWrite()...
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] HttpConnection::sendHttpError(),code=500 Internal Server Error
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] redirect to: URI=[/500.shtml], QueryString=[]
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] Find context with URI: [/], location: [/home/username/public_html/]
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] Find .htaccess context with URI: [/], location: [/home/username/public_html/]
    2013-03-02 07:36:46.740 [INFO] [my.ip:54851-0#APVH_domain.com:cgi] File not found [/home/username/public_html/500.shtml]
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] Error Page, processContextPath() return 25
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] HttpConnection::flush()!
    2013-03-02 07:36:46.740 [DEBUG] [my.ip:54851-0#APVH_domain.com:cgi] Written to client: 642

    --

    Any ideas?
  2. optize

    optize New Member

    This appears to be an issue with CloudLinux's CageFS, not Litespeed.

    Sorry
  3. NiteWave

    NiteWave Administrator

Share This Page