Why not install PHP 5.* by default in LWS 4.*

Discussion in 'LSWS 4.1 Release' started by brrr, Apr 28, 2009.

  1. brrr

    brrr New Member

    When installed, by default LSWS 3.* installed PHP 4 for all virtual hosts.

    Now that we are onto v4 of LWS, why doesn't LSWS install PHP v5 by default when you newly install LSWS?

    The jump from LSWS v3 to v4 is big enough to justify a jump from PHP 4 > PHP 5 in the default setup.
  2. closet geek

    closet geek New Member

    I agree with this.
  3. MindTooth

    MindTooth New Member

    PHP4 is also deprecated today. PHP5 is the future.

    Birger :)
  4. auser

    auser Super Moderator

    in our case, php is used in every page but minimum, so we still prefer php4 because of performance.

    if there's an option to install php4 or php5 or both during installation, that may be best in user's standpoint.
  5. ghprod

    ghprod New Member

    agree with this :)
  6. cmanns

    cmanns New Member

    Actually PHP 5.3 out does 4.x by far, even 5.2 was a milestone in performance.

    People whom spread false info, please don't. It's been released over the years that the PHP core executes FASTER, and it's laid out into which parts even.

    We have scripts executing sub .04ms with memcached and mySQL.
  7. ghprod

    ghprod New Member

    what version PHP you running?

    0.04 ms really fast :D
  8. mey

    mey New Member

    I've just installed LSWS on my server and got this error on my browser:

    "PHP version 5.1.0 or greater is required. Your PHP is version 4.4.9, please ask your host to upgrade it."

    If LSWS requires PHP 5.1, why does it ship with 4.4.9???
  9. ghprod

    ghprod New Member

    are you trying to access admin panel or what?

    i can access admin panel with default php version from lsws :)
  10. mey

    mey New Member

    I accessed the admin panel and I'm upgrading to PHP 5 now.

    It seems the error message that said it requires PHP 5 is not from LSWS but from the php software that runs my website.

    Thanks for the speedy reply!
  11. ghprod

    ghprod New Member

    great...np :)

    btw if you have any error when upgrade to php 5.3.x ... maybe you can try to run 5.2.x :D
  12. tiga

    tiga New Member

    Yes, LSWS should bundle with php5. Every time I install LSWS to a new server, I need to spend a lot of time to compile and install PHP5 manually. The compiler in admin panel always has problem.

    A very ridiculous thing is both lsphp4 and lsphp5 in fcgi-bin link to the same PHP4 binary. How lazy is the Litespeed team do this, LOL.
  13. ghprod

    ghprod New Member

    Lol, maybe they have another consideration ... :D
  14. cmanns

    cmanns New Member

    We NEED PHP 5 by default.


    This often kills WHM/CPanel boxes as the lowest PHP is 5.2 vs 4.9 or whatever litespeed ships with.

Share This Page