Won't Run Because of PHP Version =(

Discussion in 'Install/Configuration' started by mey, Jul 24, 2010.

  1. mey

    mey New Member

    I've installed LSWS Enterprise Latest, installation went smoothly until I tried it on my browser and got:

    "PHP version 5.1.0 or greater is required. Your PHP is version 4.4.9, please ask your host to upgrade it." :(

    If PHP 5.1 is required why does LSWS ship with 4.4.9?

    Then I tried upgrading PHP, I followed the direction at:

    litespeedtech.com/support/wiki/doku.php?id=litespeed_wiki:php:lsapi

    But the link to php-litespeed-4.7.tgz is broken! :(

    Where else can I get php-litespeed-4.7.tgz?




    My VPS:

    CentOS 5.3
    DirectAdmin
    2GB RAM / 80GB HD
  2. mey

    mey New Member

    The PHP version requirement is from my scripts, not from LSWS.

    The link to php-litespeed-4.7.tgz is indeed not up-to-date, but I found out I can upgrade PHP direct from the admin panel at mydomain.com:7080
  3. NiteWave

    NiteWave Administrator

  4. mey

    mey New Member

    I just switched from Apache 2 to LSWS 4.0.15

    WOW

    Server load dropped from 6 to 0.6 instantly! :D
  5. mey

    mey New Member

    I have just begun adjusting my websites to LSWS, just one issue so far and it's GeoIP.

    How to do GeoIP from PHP and .htaccess with LSWS?

    Before I could do:

    PHP:
    apache_note("GEOIP_COUNTRY_CODE");

    This is giving error now.

    .htaccess:

    RewriteCond %{ENV:GEOIP_COUNTRY_CODE} ^(RU)$

    Not giving error, but seems to be ignoring it.

    How to do GeoIP with LSWS?
  6. NiteWave

    NiteWave Administrator

  7. mey

    mey New Member

    I had it installed on my apache, since it's compatible with geoip mod_apache and it was in httpd.conf why LSWS isn't loading GeoIP?

    Maybe I have to compile GeoIP mod_apache again?

    At maxmind.com/app/mod_geoip they have 2 version, one for apache 1.3 and the other for apache 2.0. Which one should I use with LSWS?
  8. mey

    mey New Member

    I have enable GeoIP in the admin panel, and restarted it.

    But still sign of GeoIp on $_SERVER variables, also I have checked the log files and there's no error there.

    I read something about having to specify the DB path, but I can't figure out where. LSWS doesn't seem to have a variable for this on the admin panel nor the config file.

    So how to enable GeoIP on LSWS Enterprise?
  9. NiteWave

    NiteWave Administrator

    admin console --> General --> IP to GeoLocation DB
  10. mey

    mey New Member

    I specificied the path and now it's working!! :D

    In my case the path was /usr/local/share/GeoIP/GeoIP.dat

    And I'm using GeoIP mod_apache compiled for apache 2.x

    Now I can use it from PHP, retrieving the data from the $_SERVER varible.

    How to access GeoIP data from the .htaccess?

    The bellow still doesn't work:

    RewriteCond %{ENV:GEOIP_COUNTRY_CODE} ^(RU)$
  11. mey

    mey New Member

    It's working from the .htaccess too.

    Had to adjust the sintaxe from:

    RewriteCond %{ENV:GEOIP_COUNTRY_CODE} (RU)
    RewriteRule . /ru/ [L,QSA]

    To:

    RewriteCond %{ENV:GEOIP_COUNTRY_CODE} (RU)
    RewriteRule ^(.*)$ /ru/ [L,QSA]

    And now it's working! ;)

    Thanks for the replies NiteWave, they helped me get up and running much faster than I would have on my own.

Share This Page