Working PHP accelerator for PHP 5.2.8

Discussion in 'PHP' started by Henk Poley, Jan 11, 2009.

  1. Henk Poley

    Henk Poley New Member

    Is there a working PHP accelerator when building PHP 5.2.8 with the web interface? PHP build fine, and the .so's seem to load, but I only get "Error 503" on my PHP sites (the phpinfo page by Litespeed works though).
  2. MindTooth

    MindTooth New Member

    Hello.

    Just received the same problem. And the fix is that the lsphp file inside fcgi-php isn't updated. You need to create a symlink to lsphp-5.2.8 inside the same folder.

    Guide:
    Navigate to your lsws folder, open fcgi-php and first move lsphp to lsphp.bak2, next is to create a symlink to lsphp-5.2.8. Can be achived by following command: sudo ln -s lsphp-5.2.8 lsphp.

    I hope this fix it.

    Birger :)
  3. Henk Poley

    Henk Poley New Member

    Thank you, that put me on the right track. btw, a better way would be to point your Virtual Host "External App" config to $SERVER_ROOT/fcgi-bin/lsphp5 (instead of lsphp).

    Some old tutorials from before when Litespeed buildscripts supported PHP5 told you to just replace the default lsphp with the PHP5 binary you built by hand. Apparently I have been running a PHP5 from dec 8 2007 all along, only with new PHP5 script-libraries. Whoops..
    Last edited: Jan 11, 2009
  4. anewday

    anewday Moderator

    I think 3.3.24 fixes this problem. No problems with 5.2.8 on my server.
  5. Henk Poley

    Henk Poley New Member

    When you never built PHP5 by hand and replaced lsphp (PHP4), you won't have this problem. Also, 3.3.24 doesn't seem to be released.
  6. anewday

    anewday Moderator

    You can just change the version on the download link. :)
  7. mistwang

    mistwang LiteSpeed Staff

    The newly built PHP5 binary will be copied to lsws/fcgi-bin/lsphp-5.xxxx , and symbolic linked to lsws/fcgi-bin/lsphp5 . So, use "lsphp5" will always give you the latest.

Share This Page