Xcache Headache

Discussion in 'Install/Configuration' started by paulg1981, Dec 1, 2008.

  1. paulg1981

    paulg1981 New Member

    Hello,
    I have successfully installed litespeed and compiled php with the web interface. I have added "extension=xcache.so" and removed any data in the "extension_dir=""" variable in php.ini

    The problem is that phpinfo shows xcache 1.2.2 but when I try to use the admin folder (copied from the source folder to my web root) It says Xcache not loaded? The site is running slower than it did previously with litespeed and xcache also so I know it isn't working properly? Any ideas?

    Thanks for any help you can provide :)
  2. paulg1981

    paulg1981 New Member

    No One? Please help me out!
  3. mistwang

    mistwang LiteSpeed Staff

    Just create a phpinfo() page under the admin folder to verify if xcache get loaded or not.
    Also, you may want to disable PHP suEXEC to make all PHP processes to share the same cache memory if your server is not for shared hosting.
  4. paulg1981

    paulg1981 New Member

    Okay now I am more confused, the phpinfo in the admin folder shows php 4.4.9 with no xcache? The phpinfo from the litespeed placeholder page shows 5.2.6 with xcache....How do I make ls use the newer version or what did I miss? Thanks for any help you can provide!
  5. paulg1981

    paulg1981 New Member

    Okay I got it!

    It appears that lsphp was not replaced with the new build when it was compiled? I copied lsphp-5.2.6 to lsphp and voila! Thanks for the tip mistwang :)
  6. mistwang

    mistwang LiteSpeed Staff

    Open web console, and change server level script handler for "php4" from "lsphp4" to "lsphp5".
  7. fastproxy

    fastproxy New Member

    I think you edited the wrong PHP.ini file,
    try to use Phpinfo() and see which PHP.ini is loading, and edit that file with your xcache info

Share This Page