Zope rewrite problem

Discussion in 'Install/Configuration' started by telesma, Jan 4, 2010.

  1. telesma

    telesma New Member

    First, happy new year to you all!

    I want to use LSWS in front of Zope and added a virtual host with a rewrite rule and a webserver as an external app.

    The rewite rule looks like this:

    Code:
    RewriteRule ^/(.*) /live/josephheeg/VirtualHostRoot/$1
    RewriteCond HTTP_HOST !:
    RewriteRule ^(.*) localhost:8080/VirtualHostBase/http/%{HTTP_HOST}:80/$1 [P,L]
    The rule is working fine, but when I hit reload in the browser LSWS hangs... I think it has something to do with the ports in the rewrite rule... When I change the rule to

    Code:
    RewriteRule ^(.*) localhost:8080/VirtualHostBase/http/%{HTTP_HOST}:8080/$1 [P,L]
    the behaviour is fine even with browser reload.

    You can have look at it:
    Code:
    telesma.dyndns.org

    Any suggestions would be great!
    Frank

    ps. I can't post links, so I removed the h t t p : / / from the rules
  2. mistwang

    mistwang LiteSpeed Staff

    Most browser wont send ":80" in the URL, just strip it. it might be the reason why.
    Not something wrong with the rewrite rule, just browser do not want to do what you want and causes looping redirect between web server and browser.
  3. telesma

    telesma New Member

    Thank you! Stripped the ":80", but the problem persits.
  4. mistwang

    mistwang LiteSpeed Staff

    It wont fix the problem. You should turn on debug logging and rewrite log, and analyze why from the log.

Share This Page