4.0.10 Upgrade Problem - Configuration Files Not Valid

Discussion in 'Install/Configuration' started by sdc888, Aug 21, 2009.

  1. sdc888

    sdc888 Member

    I'm having a few issues with the 4.0.10 upgrade:

    1.) I cannot access the configuration files for any of my virtual hosts -- I am seeing the following error message in red when clicking on the configuration for a virtual host (these worked fine in 4.9):

    /home/myusername/public_html/config/mywebsite.com.xml is not a valid file.

    2.) When downgrading back to 4.9 -- I am receiving a session error message and a 503 error on my website.

    Any idea what might be wrong?

    Last edited by a moderator: Aug 21, 2009
  2. mistwang

    mistwang LiteSpeed Staff

    4.0.10 uses suEXEC for the web console, running as user lsadm.
    So, you may need to update directory/file permission for your custom configuration file if they are in the default conf/ directory.

    If you want to downgrade to 4.0.9, I strongly suggest you not to, you need to run the installer of 4.0.9 to change the directory/file permission of the admin console related back to previous setting.
  3. sdc888

    sdc888 Member

    I changed owner/group of my virtual host config file (mysite.com.xml) to lsadm from (www-data:www-data), and also changed the owner/group of the config folder to lsadm, restarted the process, but still no luck. When clicking on any virtual host within the 4.10 admin console, i see the following message in red:

    /home/myusername/public_html/config/mywebsite.com.xml is not a valid file.

    Any other ideas? As a side note I keep all of my virtual host config files in directories separate from the main lsws server config files.

    Here's a paste of my updated config file permissions:

    -rw-r--r-- 1 lsadm lsadm 3238 Jun 15 19:35 mysite.com.xml
  4. mistwang

    mistwang LiteSpeed Staff

    You also need to check the ownership and permission of /home/myusername and /home/myusername/public_html.

    It may not be a good idea to put configuration file under public_html.

Share This Page