4.0 RC1 release

Discussion in 'Bug Reports' started by mistwang, Feb 3, 2009.

  1. mistwang

    mistwang LiteSpeed Staff

    4.0 RC1 release is available now.

    The goal of this release is to stabilize 4.0 release and get read y for 4.0 official release, so there is no major new feature added, in order not to further delay 4.0 release some features planed for 4.0 are rescheduled for 4.1 release.

    4.0 RC1 release include main features: SSI (Server Side Include), mod_security 2.x rule support, large file and mod_cache. It makes conversion from Apache 2.x a lot easier.

    4.0 RC1 release should be stable for production use as some hosting companies already use it on production servers.

    Special thanks to Tony from Hawkhost.com, who has submitted many bug reports and provided assistances in fixing those bugs.

    Packages for all platforms are available now

    Linux (x86)

    Linux (x86_64)

    FreeBSD 4/5 (x86)

    FreeBSD 6.x (x86)

    FreeBSD 6.x (x86_64)

    Mac OSX (Intel)

    Mac OSX (PPC)

    Solaris (x86)

    Solaris (x86_64)

    Solaris (SPARC)

    For standard release package, just change "ent" to "std" in the download link.
  2. Tony

    Tony Well-Known Member

    I was just motivated to not have to run Apache at all :)
  3. AquariusRyan

    AquariusRyan New Member

    Aquariusstorage.com has also been running rc1 in a production environment (across all live web hosting webservers) for about a week and honestly haven't had one complaint at all. Sorry for the lack of bug reports, but we simply cant find any....very stable, and we was very happy to finally be able to kill Apache :)
  4. Michael.Terence

    Michael.Terence Active Member

    Is there any way upgrade via the ./install.sh script from my current installation?
  5. mistwang

    mistwang LiteSpeed Staff

    Yes, just run the installer to upgrade.
  6. Invictus

    Invictus Member

    I have set the cache directory to /tmp/lshttpd/swap
    Is it correct configuration to enable Cache function?
  7. justme

    justme Well-Known Member

    large file support


    running 4.0rc1 on x86-32bit, I see that >2GB files are still returning 404, do I need to do something to enable large file support?

  8. justme

    justme Well-Known Member

    lscgid: request validation failed!
    after the upgrade :(
    2009-02-06 15:08:58.031 NOTICE [aa.bb.cc.dd:47888-0#Example] Content len: 0, Request line:
    GET /cgi-bin/collection.cgi/cpu/hour HTTP/1.1
    2009-02-06 15:08:58.031 DEBUG [aa.bb.cc.dd:47888-0#Example] Find context with URI: [/cgi-bin/], location: [/usr/lib/cgi-bin/]
    2009-02-06 15:08:58.032 DEBUG [HTAccess] Updating configuration file [/usr/lib/cgi-bin/.htaccess]
    2009-02-06 15:08:58.032 DEBUG [aa.bb.cc.dd:47888-0#Example] processContextPath() return 0
    2009-02-06 15:08:58.032 DEBUG [aa.bb.cc.dd:47888-0#Example] run cgi processor.
    2009-02-06 15:08:58.032 DEBUG [uds://usr/local/lsws/admin/conf/.cgid.sock.241] create new connection succeed!
    2009-02-06 15:08:58.032 DEBUG [uds://usr/local/lsws/admin/conf/.cgid.sock.241] request [aa.bb.cc.dd:47888-0#Example:cgi] is assigned with connection!
    2009-02-06 15:08:58.032 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] [ExtConn] reconnect()
    2009-02-06 15:08:58.032 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] [ExtConn] connecting to [uds://usr/local/lsws/admin/conf/.cgid.sock.241]...
    2009-02-06 15:08:58.032 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] ExtConn::eek:nWrite()
    2009-02-06 15:08:58.032 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] CgidConn::eek:nWrite()
    2009-02-06 15:08:58.032 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] request header is done
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] ExtConn::continueRead()
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] Request body done!
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] ExtConn::suspendWrite()
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] ExtConn::suspendWrite()
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] processNewReq() return 0.
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] ExtConn::eek:nRead()
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] CgidConn::eek:nRead()
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] process STDOUT 46 bytes
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] response header finished!
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] HttpExtConnector::processRespBodyData()
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] use CHUNKED encoding!
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] Written to client: 216
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] writeRespBody() return 34
    2009-02-06 15:08:58.033 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] response buffer is empty, suspend HttpConn write!
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] HttpIOLink::suspendWrite()...
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] m_pHandler->onWrite() return 1
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] ExtConn::eek:nError()
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] CgidConn::eek:nError()
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] [EXT] EndResponse( endCode=0, protocolStatus=0 )
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] release ExtProcessor!
    2009-02-06 15:08:58.034 DEBUG [idle] [ExtConn] close()
    2009-02-06 15:08:58.034 DEBUG [uds://usr/local/lsws/admin/conf/.cgid.sock.241] add recycled connection to connection pool!
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] HttpIOLink::continueWrite()...
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] write resumed!
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] HttpIOLink::handleEvents() events=4!
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] ReqBody: 0, RespBody: 34, HEC_COMPLETE!
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] m_pHandler->onWrite() return 0
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] Written to client: 7
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] HttpConnection::flush()!
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] HttpConnection::nextRequest()!
    2009-02-06 15:08:58.034 DEBUG [aa.bb.cc.dd:47888-0#Example:cgi] HttpExtConnector::cleanUp() ...
  9. anewday

    anewday Moderator

    You need to enable the large file support during installation.
  10. mistwang

    mistwang LiteSpeed Staff

    Really? it should work.
    please enable debug logging and send us the log.
  11. mistwang

    mistwang LiteSpeed Staff

    the lscgid should be updated, please check the size of lsws/bin/lscgid.
    Try a restart, see if it works.
  12. justme

    justme Well-Known Member

    lrwxrwxrwx 1 root root 13 2009-02-06 11:15 httpd -> lscgid.4.0rc1
    lrwxrwxrwx 1 root root 15 2009-02-06 11:15 lscgid -> ./lscgid.4.0rc1
    -r-sr-xr-x 1 root root 11680 2008-11-11 09:33 lscgid.3.3.22
    -r-sr-xr-x 1 root root 11680 2009-02-01 16:28 lscgid.3.3.24
    -r-sr-xr-x 1 root root 11268 2009-02-06 11:15 lscgid.4.0rc1
    tried a restart, no go. Kernel is 2.6.27 (config ftp://ftp.ovh.net/made-in-ovh/bzImage/2.6-config-xxxx-std-ipv4-32) on ubuntu gusty.
    By the way I did paste debug logging in a previous post, do you need more?
    Last edited: Feb 7, 2009
  13. justme

    justme Well-Known Member

    I did upgrade from 3.3.24 and I don't recall seeing this option, can I turn it on after install?
  14. mistwang

    mistwang LiteSpeed Staff

    That's for cgid problem, not for 404 error caused by large file.
  15. mistwang

    mistwang LiteSpeed Staff

    It is enabled by default.
  16. mistwang

    mistwang LiteSpeed Staff

    Maybe I need a temp root access to check your server.
  17. Michael.Terence

    Michael.Terence Active Member

    Hey mistwang, any ideas as to why I can't get the cache to work? I posted back on page 1.

  18. mistwang

    mistwang LiteSpeed Staff

    To enable cache for vhost configured through Apache httpd.conf, directive

    CacheEnable ...

    should be set for the vhost or from .htaccess
  19. Michael.Terence

    Michael.Terence Active Member

    We're not using the apache config - just the configs from litespeed
  20. mistwang

    mistwang LiteSpeed Staff

    Then you need to configure the "cache" tab at server level, if it is not enabled at server level, you need to enable cache at vhost level.
    "Cache-Control" response header may prevent LSWS from cache the response. you can try adjust the cache configuration.

    You can start with a simple phpinfo() page.

Share This Page