404 Not Found when setting up a Rails App

Discussion in 'Ruby/Rails' started by catalystmediastudios, Feb 28, 2008.

  1. Hi,

    I'm trying to set up a rails app in development mode on my dev machine using LiteSpeed. I followed the articles: http://www.usefuljaja.com/litespeed about rails.

    When I installed litespeed I installed it to usr/local/lsws and put it in the paul user in the users group (the same one as my user, does not have root access). LiteSpeed should automatically have read/write without my explicity setting ownership (though I did set ownership just in case) to my rails app folder (which is /home/paul/Desktop/MyRailsApps/app_name/). So I used the template to set up my rails app and changed concurrent connections to 1 mode to development and the virtual host root to "/home/paul/Desktop/MyRailsApps/app_name/public/" and pointed the rails "context" to "/home/paul/Desktop/MyRailsApps/app_name/".

    Then I set up a listener on any IP and the port "*" and set the virtual host mapping to the vhost described above. When I gracefully restart the server, and go to http://localhost it shows me a LiteSpeed 404 Note Found error. Any ideas? I gave as much info as I thought necessary, but if you need more let me know. I'm very new to LiteSpeed so I don't knwo what else you may need.

    Thank You,
  2. mistwang

    mistwang LiteSpeed Staff

    Should set virtual host root to "/home/paul/Desktop/MyRailsApps/app_name/".
    Please check the server log for errors, if need, turn on the debug logging.
  3. Hmm I changed it but it still didn't work. I tried turning on debug logging and I went to the actions > server log and nothing was showing up that looked out of the ordinary. I'm assuming that it is the rails app that is not booting up, because it does find LiteSpeed, it just doesn't seem to direct to the rails app. Should I post the xml version of the app config? maybe the logs too?

    BTW thank you or the extremely quick response.

    Oh and I installed the ruby-LSAPI gem as well.
    Last edited: Feb 28, 2008
  4. mistwang

    mistwang LiteSpeed Staff

    Yes, you can post your config and logs.
  5. Hmm well I uninstalled litespeed then reinstalled it and it worked fine this time...oh well haha. Thanks for the help and amazingly fast response.

Share This Page