500 error with /cpanel

Discussion in 'General' started by Victor, Feb 20, 2013.

  1. Victor

    Victor New Member

    In one of our server, when taking domain.com/cpanel internal server
    error generated. On switching to apache it load fine. Do you have any
    idea regarding this.

    I have tried force lsws reinstall which didn't fix the issue
  2. webizen

    webizen Well-Known Member

    check error_log and stderr.log in /usr/local/apache/logs when issue happens.
  3. staff

    staff New Member


    We are having the same error(500 Internal Server Error) when calling domain.com/cpanel, /webmail etc.

    We tried to increase the Timeout value in "/usr/local/lsws/conf/httpd_config.xml" but no luck. Also we checked error_log in "/usr/local/apache/logs" and got the following in it.

    2013-02-24 04:46:04.611 [NOTICE] [208.x.x.x:33290-0#APVH_domain.com] Premature end of response header.
    2013-02-24 04:48:16.595 [NOTICE] [208.x.x.x:33290-0#APVH_domain.com] Premature end of response header.

    Nothing generates on stderr.log. This is working fine when switching from litespeed to apache. Please help!!!
  4. staff

    staff New Member


    No support associate's here? Our clients need this feature back, we are asking for a solution to this since litespeed is a product of yours. Please understand and help us.

    Waiting for a response.
  5. webizen

    webizen Well-Known Member

    What's the lsws version in use?
  6. staff

    staff New Member


    Litespeed version we are using is 4.2.1.

    Please assist.
  7. NiteWave

    NiteWave Administrator

  8. staff

    staff New Member


    Thank you but it is not working in our server, its litespeed there.

    /cpanel, /webmail etc working fine when we switch webserver to apache, but litespeed gives only 500 error.

    your staff webizen said its a bug through my private message and the developer was checking at it, but no updates till now :(
  9. webizen

    webizen Well-Known Member

    This has to do with CloudLinux LVE for this particular server. Our test server in Lab that has CL LVE does not exhibit the problem.

    strace shows that when lscgid (handles /cpanel cgi redirect) crashed when enter LVE. Hence 500 error. If CloudLinux is set to Disabled in LSWS (Admin Console => Configuration => Server => General), 500 error is gone. 500 error re-appears when set to LVE.

    More to come.
  10. jacob

    jacob Member

Share This Page