503 error / connection reset by peers / Wordpress

Discussion in 'Install/Configuration' started by canglan, Oct 9, 2009.

  1. canglan

    canglan Member


    We are experiencing 503 errors on a particular Wordpress plugin (wpUserLinks). Every time a user submits a POST form, it responses 503.

    The following is the error log:

    2009-10-08 21:40:05.961 [INFO] [xxx] connection to [/tmp/lshttpd/lsphp5.sock] on request #176, confirmed, 1, associated process: 11316, running: 1, error: Connection reset by peer!
    2009-10-08 21:40:05.961 [NOTICE] [xxx] Request in process stage, fail with 503
    2009-10-08 21:40:05.961 [NOTICE] [xxx] oops! 503 Service Unavailable
    2009-10-08 21:40:05.961 [NOTICE] [xxx] Content len: 144, Request line:
    POST /link-feed/ HTTP/1.1
    2009-10-08 21:40:05.961 [NOTICE] [xxx] Redirect: #1, URL: /index.php

    If reverted back to Apache, no issues at all.

    We've tried to tweak all sorts of configurations in LSWS but no dice. Any suggestions?

    EDIT: LSWS 4.0.10, PHP 5.2.10
    Last edited: Oct 9, 2009
  2. mistwang

    mistwang LiteSpeed Staff

    looks like PHP crashed in the middle of processing the request.

    Make sure you using the same PHP version for both Apache and LiteSpeed, with similar configuration options.
    If the plugin uses a lot of memory, you need to increase the memory limit.
  3. canglan

    canglan Member

    Thanks for the suggestion George.

    We've tried to increase the PHP memory size to almost 1GB, didn't help.

    The PHP version aren't the same. It's 5.2.5 on Apache vs 5.2.10 on LSWS, however, the configurations are exactly the same. I've compared phpinfo and made sure of it.

    We are using APC, but I've disabled APC and the problem still persists.

    Any other settings we can tweak other than memory limit?
  4. mistwang

    mistwang LiteSpeed Staff

    Compile PHP 5.2.5 for LSWS see if the problem disappear.
    Or try 5.2.11. likely a PHP bug.
  5. canglan

    canglan Member

    Looks like it's a PHP bug. I've compiled 5.2.11 and it's now working fine.

    Thanks George!
  6. anewday

    anewday Moderator

    PHP 5.2.10 has a lot of problems based on previous posts here.
  7. Josh

    Josh New Member

    FYI, I ran into a similar issue (503's on certain Wordpress pages, etc.) and I went from PHP 5.3 back to PHP 5.2.13 and the 503's went away.

Share This Page