Add QUIC version 43 to LSWS 5.2.8

Discussion in 'General' started by Àlex Miras, Jul 3, 2018.

Tags:
  1. Àlex Miras

    Àlex Miras Member

    In LSWS Admin I have the QUIC Versions parameter not set and the header shows
    Code:
    alt-svc: quic=":443"; ma=2592000; v="35,37,38,39"
    The HTTP/2 and SPDY indicator says http2 enabled and no green icon :/
    But here, I can see that this forum has SPDY+quic/43
    Code:
    alt-svc: quic=":443"; ma=2592000; v="35,39,43"
    How can I enable QUIC version 43 and why it's not enabled by default?
     
  2. mistwang

    mistwang LiteSpeed Staff

    QUIC/43 support should be in 5.3RC1 already. 5.2.8 only support up to QUIC/39.
    You can try 5.3RC1 with command
    /usr/local/lsws/admin/misc/lsup.sh -f -v 5.3RC1
     
    Àlex Miras likes this.
  3. Àlex Miras

    Àlex Miras Member

    Is it safe to upgrade? I would like to test the criu features also but I'm in a production server :/
    I've been thinking for a couple of weeks that something was wrong with my QUIC configuration
     
  4. mistwang

    mistwang LiteSpeed Staff

    It should be safe. worst case is downgrade back to 5.2.8 .
    my chrome is still speaking QUIC/39 now, you should double check if UDP port 443 has been opened.
     
    Àlex Miras likes this.
  5. Àlex Miras

    Àlex Miras Member

    I have the 68.0.3440.42 version (Beta channel I think) and it seems that only wants the 43 version of QUIC
    I have CSF with 443 udp ports open and was working a few weeks ago (tested with the directions here).
    I'll test the RC, you're right, I can downgrade If things go wrong
    Thanks a lot for your help mistwang
     

Share This Page