Apache 2 to litespeed

Discussion in 'Bug Reports' started by sif3r, Jul 11, 2010.

  1. sif3r

    sif3r Member

    Hi i'am replacing apache2 to litespeed trial and any vhost dont work :/

    my system is debian 4 , directadmin
    number of domains : 7238

    Pleas help
  2. NiteWave

    NiteWave Administrator

  3. sif3r

    sif3r Member

    Hi i check this , error was in the ip settings for vhosts .
    instead of * 80 was , change this solved my problem.

    I have the next error, every now and then shows an error 503

    is nightmare.

    Thanx for reply.
  4. NiteWave

    NiteWave Administrator

  5. sif3r

    sif3r Member

    I build php 5.2.13 and 5.2.12 and this same error , my system is debian 4 . System is too old ? for new litespeed ?

    in my error log is :

    2010-07-12 15:55:35.761 [NOTICE] [adres_ip:47805-0#APVH_www.domain.com] Max retries has been reached, 503!
    Last edited: Jul 12, 2010
  6. NiteWave

    NiteWave Administrator

    many reason will cause 503 error -- for example,no enough memory assigned to php process.

    just mention one here:
    check php.ini, list all start wirh
    extension= ...

    and comment all of them, and see of 503 error gone.
  7. sif3r

    sif3r Member

    This is clean install php , no ioncube , no any opcode cache nothing.
    Error 503 still exist .
    I noticed that the domain which have fewer than 10 characters work well and which are the domain of more than 10 characters long show 503 error
  8. NiteWave

    NiteWave Administrator

    how about non-PHP page?
  9. sif3r

    sif3r Member

    it's ok.

    On php 4 is fine , in php5 is 503 error
  10. mistwang

    mistwang LiteSpeed Staff

    try to execute "/usr/local/lsws/fcgi-bin/lsphp5 -i" from command line, see if you get any error and fix it.
  11. cmanns

    cmanns Well-Known Member

    Good help sir.

    I'd also suggest setting up apache 2.2 mpm event + php5-fastcgi.

    Then setup litespeed PHP when php5-fastcgi functions with apache.

    Run php-cgi -v & php-cgi -M?/-m you may have it as php5-cgi on debian not sure.

    This will show errors too.

    Lastly you can strace -p any php processes you see and check the issue. This is how I discovered WordPress w/Missing mods eats up pointless CPU cycles.

Share This Page