Apache HTTP Server Required

Discussion in 'Install/Configuration' started by pooyan, Jul 20, 2011.

  1. pooyan

    pooyan Well-Known Member

    Hello

    Please see the attachment
    When i Switch to Apache problem fixed

    please help me


    many thanks
     

    Attached Files:

  2. NiteWave

    NiteWave Administrator

    you may need modify "sharetronix" script, to force it to recognize litespeed as apache.
     
  3. pooyan

    pooyan Well-Known Member

  4. webizen

    webizen Well-Known Member

    have you built matching PHP in LSWS? also check the error.log for error details.
     
  5. pooyan

    pooyan Well-Known Member

    please check it

    PHP:
    nable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20060613/ixed.5.2.lin' - /usr/lib/php/extensions/no-debug-non-zts-20060613/ixed.5.2.lincannot open shared object fileNo such file or directory in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  PHP StartupUnable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20060613/suhosin.so' - /usr/lib/php/extensions/no-debug-non-zts-20060613/suhosin.socannot open shared object fileNo such file or directory in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  PHP StartupUnable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20060613/eaccelerator.so' - /usr/lib/php/extensions/no-debug-non-zts-20060613/eaccelerator.socannot open shared object fileNo such file or directory in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'pdo_sqlite' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'SQLite' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  Module 'pdo_mysql' already loaded in Unknown on line 0
    [20-Jul-2011 19:54:53PHP Warning:  PHP StartupUnable to load dynamic library '/usr/lib/php/extensions/no-debug-non-zts-20060613/ixed.5.2.lin' - /usr/lib/php/extensions/no-debug-non-zts-20060613/ixed.5.2.lincannot open shared object fileNo such file or directory in Unknown on line 0
     
  6. webizen

    webizen Well-Known Member

    these warnings may not be necessarily related to the blank page issue. you need to tail the error log when request http://linkrooz.com/members to see any errors related to that.

    for these warnings, you need to clean up duplicate entries like 'extension=PDO.so' php.ini. to find out which php.ini in use, do below from command line:
    where /path/to/lsws is the installed path of lsws (e.g. /usr/local/lsws)
     
  7. pooyan

    pooyan Well-Known Member

    When i Switch to Apache all page display good
    but, when i Switch to Litespeed some pages not work

    i recompiled easyapache and Build Matching PHP Binary
    i attached Build Matching PHP Binary log, please check it

    many thanks
     

    Attached Files:

  8. webizen

    webizen Well-Known Member

    Matching PHP build seems to be done successfully. Please do 'tail -f /usr/local/apache/logs/error_log' when point your browser to http://linkrooz.com/members and see if any errors.
     

Share This Page