binding question

Discussion in 'Install/Configuration' started by Shelby, Sep 21, 2006.

  1. Shelby

    Shelby Member

    I am running a server with standard edition version 2.2. I had the server in my home, testing and loading it with web pages and ruby apps. All was working well. At first, I had it set to private IP address space, then before the move, I changed it to the public IPs that I would use when I put the server in production. All was working well.

    When I took the server to my colo facility, and started it up, the only page that would show was the admin page. None of the other virtual hosts would show. It appeared that the litespeed would not bind to port 80, even though it was being started as root. I ended up checking the Binding checkbox under each listener (next to where it says "Process 1"). Whatever that did, it forced the server to bind to port 80, then all worked fine.

    The docs say that the binding checkbox only works with the enterprise edition, but obviously it did something here. I do not understand why it worked fine in my house without this checkbox checked, but I had to do it when I move the server to the colo. Anyone have any ideas?

  2. xing

    xing LiteSpeed Staff

    Binding listner to a process is only applicable to enterprise version and unless needed, should be left untouched.

    Not sure what happened to your setup and when it happens again, check the log/error.log and log/stderr.log files to see if there are any unusual output there.

    Most likely your listener was bound to a non-exisitent ip when you copied the configuration from your home server to the colo server. Once you "touched" the config, made minor change, the web admin was able to auto-correct the bind/ip settings.

Share This Page