bug in .htaccess-interpretation? (2.1.1)

Discussion in 'Bug Reports' started by ts77, Sep 26, 2005.

  1. ts77

    ts77 Well-Known Member

    I have that section in my .htaccess-file:
    Options +ExecCGI
    DirectoryIndex viewer.prg
    Order allow,deny
    Allow from none
    Deny from all
    <Files ~ "\.prg$">
    Order deny,allow
    Deny from none
    Allow from all
    That should allow only .prg-files as far as I understand (that file was distributed from the vendor that sold the cms).
    Before lsws 2.1 that worked without problems but now I still get a "forbidden"-reply as if the files-section is not working.

    any ideas?
  2. IO

    IO Active Member

    You can try simply this :
    <Files ~ "\.prg$">
    Order allow,deny
    Allow from all
    (Order changed and without Deny from none)
  3. mistwang

    mistwang LiteSpeed Staff


    It work pretty well for me. :)

    Looks like it is not because <files> section.

    Have you checked the error.log?

  4. mistwang

    mistwang LiteSpeed Staff

    I got another report that .htaccess stop working after LSWS run for a while, please try a restart, see if it works for a while, then stop working again.

  5. ts77

    ts77 Well-Known Member

    Sorry, I hadn't have time to test it out further until today.

    Thanks for your suggestions but both don't work.
    The change from IO didn't change anything and it also doesn't stop after a while, it just never works ;).

    I could track it down now to being related to the .htaccess-file in the directory above.
    Once I remove the rewrite-rules in the .htaccess-file in the directory above it gives me access (as requested by the .htaccess-file) but the rewrites just don't work then.

    the rewrites are as follows (just anonymized):
    RewriteEngine on
    RewriteRule !.*xxx*.        -       [C]
    RewriteRule (^.*prg$)           /cgi-tdb/xxx/xxx/efwm4/programm/$1
    also I got a core-dump while playing with this stuff but that one will be sent by mail :).

    Error-log only tells
    2005-09-30 11:42:08.823 [INFO] [xxx.xxx.163.80:1760-0#domain.de][ACL] Access to context [/xxx/programm/] is denied!


Share This Page