Build Matching Binary Fails

Discussion in 'PHP' started by imagize, Sep 20, 2008.

  1. imagize

    imagize Member

    The build seems to complete successfully, and then at the end it displays this error:

    Obviously the directory doesn't exist, just wondering how to solve this.

    Also If I try to build php5 in the lsws admin panel, I get all sorts of permission errors like:

    I assume this is because lsws is running as robody and doesn't have permission.



    I compiled lsphp5 manually and it works fine, still curious why the other methods didn't work though.
    Last edited: Sep 20, 2008
  2. mistwang

    mistwang LiteSpeed Staff

    Which OS are you using?
    Looks like the PHP code has not been properly patched when you build matching binary from WHM, it should grab the latest PHP LSAPI patch and create /home/cpeasyapache/ls.src/php-5.2.6/sapi/litespeed/ directory. Is the directory created?

    Please try it again see if there is any other error messages.
  3. imagize

    imagize Member

    I'm using CentOS 64bit, I was able to build php manually but I could not get APC working correctly.

    I could compile APC but it was acting weird, like when the shm size was set to 100, it was showing a total of 600, it was like it was not sharing properly.

    Also could be a conflict between the APC compiled with apxs running with apache. I was running litespeed in paralells to test.
  4. imagize

    imagize Member

    There were lots of these logs:

  5. mistwang

    mistwang LiteSpeed Staff

    Maybe you need increase the memory limit, in both php.ini and the lsphp? external application from LSWS web console.
  6. R.Rowan

    R.Rowan Member

    I am getting the same error when trying to rebuild PHP. I stopped litespeed to install some new php modules and when I go to rebuild php it gives me the following error:

    copy compiled php binary to litespeed directory
    cd /usr/local/lsws/fcgi-bin
    cp: cannot stat `/home/cpeasyapache/ls.src/php-5.2.6/sapi/litespeed/php': No such file or directory
    **ERROR** fail to copy lsphp from /home/cpeasyapache/ls.src/php-5.2.6/sapi/litespeed/php

    The directory does exist though.
  7. mistwang

    mistwang LiteSpeed Staff

    You can try removing /home/cpeasyapache/ls.src/ directory and try again.
  8. R.Rowan

    R.Rowan Member

    I tried removing it, uninstalled litespeed, reinstalled and it still fails.
  9. mistwang

    mistwang LiteSpeed Staff

    Please try rebuild Apache/php with ezapache first.
  10. R.Rowan

    R.Rowan Member

    Just to update, the fix to this problem was with /usr/bin/gcc - if you set permissions to 755 before the compilation it works fine. Make sure to change it back to normal after.

Share This Page