Build Matching PHP Binary does nothing

Discussion in 'Apache Migration/Compatibility' started by Heritz, Oct 25, 2010.

  1. Heritz

    Heritz Member

    So, I installed the WHM plugin. It downloaded/installed LSWS with a trial key, etc.

    I can see the "LiteSpeed Web Server Plugin" option in my WHM. However, when I click "Build Matching PHP Binary", nothing happens.

    On Firefox: I get a blank screen. Checking with Firebug the response is "Failed to load source for: ht*p://XXYYXYYX:2086/cgi/lsws/index.php?do=buildPHP"

    On Google Chrome: Error 321 (net::ERR_INVALID_CHUNKED_ENCODING): Unknown error.

    On IE8: Internet Explorer cannot display the webpage.

    On Safari: The error is: “unknown error” (CFURLErrorDomain:303)

    I tried uninstalling and reinstalling the LSWS but I am still getting the same error. What else can I do?

    I also tried "chmod 0755 /usr/bin/gcc" but still getting the same errors on WHM.
  2. webizen

    webizen Well-Known Member

    Please build the PHP from EasyApache (within cPanel) first and see if that makes any difference. BTW, what's the release version of your cPanel?
  3. Heritz

    Heritz Member

    This is what I'm using:

    WHM 11.26.20
    CENTOS 5.5 x86_64 standard on server
  4. Heritz

    Heritz Member

    Nope. Did a "rebuild" with easyapache, but it didn't solve the problem. I am still getting a blank screen.
  5. webizen

    webizen Well-Known Member

    Anything in cPanel logs as to what's wrong with building php? PM me your server access for me to take a look if you would like.
  6. Heritz

    Heritz Member

    Got it working.

    Just started LS from console

    [your_install_dir]/bin/lswsctrl start

    Then compiled PHP from within the LS admin panel itself. Then it worked.

    Thank you.
  7. webizen

    webizen Well-Known Member

    There is no 'Build Matching PHP' option in LS admin panel. Guess you are talking about the Compile PHP in Action menu.

    From cPanel WHM, Build Matching PHP usually does not need LSWS running. So Apache was not running before you started LSWS from console, right?
    Last edited: Oct 26, 2010

Share This Page