bytelog configured in LSWS vhost doesn't work.

Discussion in 'Bug Reports' started by Xorlev, Dec 27, 2007.

  1. Xorlev

    Xorlev Well-Known Member

    I'm running LSWS 3.3.3 on CentOS Enterprise 4.6 i686.

    It is a dynamic site.

    I posted about a problem I had with the LSWS bytelogger a few months back, and just now checked to see if it had been resolved.

    I checked today to see if LSWS had started properly logging bytes again, but as of yet the answer is still no. The file permissions are as follows:

    -rw-rw-rw- 1 nobody nobody 0 Nov 30 23:16

    The vhost in LSWS has /usr/local/apache/domlogs/ configured as byte log path, runs as nobody:nobody, all have read/write access to it, but it still doesn't write the log. It appeared to work correctly until 02/13/07 or so, the date of the last log rollover. Any ideas? Is this a problem with LSWS, or my configuration? It is strange though that it would suddenly decide all those months ago to quit working.

    Also, if you all have time, it'd be nice if we could configure the bytelog rollover/compression/etc. separate from the access log. I'd actually prefer it didn't rollover at all, though it did (while it was still working) on multiple occasions.
    Last edited: Dec 27, 2007
  2. mistwang

    mistwang LiteSpeed Staff

    You need to check the permission of domlogs directory as well.
  3. Xorlev

    Xorlev Well-Known Member

    drwxrwx--x 59 root nobody 124K Dec 27 13:23 domlogs/

    Group has read/write/execute permissions. The server has been reloaded. Should this not be sufficient?
  4. mistwang

    mistwang LiteSpeed Staff

    Is the byteslog configured through Apache httpd.conf? created by cPanel? If yes, which version of cPanel is used? Please show me the configuration section related to it. If all vhosts are configured with LSWS configuration natively, please show me an example of the configuration as well.

    If you remove the empty log file, will it get recreated automatically?
  5. mistwang

    mistwang LiteSpeed Staff

    Have checked a few cPanel 11.11.0 servers, byte logging works fine.
  6. totalnet

    totalnet Member

    I am having the same problem with byteslog file not showing up. I use the native LSWS web config turn on byteslog setting. Below is the section from vhost config file. I do see the access log file, but no byte log file. LSWS standard v3.3.3,

  7. Xorlev

    Xorlev Well-Known Member

    No, it's natively configured through a LSWS vhost somewhat like the above.
  8. mistwang

    mistwang LiteSpeed Staff

    OK, this issue has been identified and fix has been committed to the 3.3.4 release.
    Sorry for the delay, we do need a little bit more detail in the bug report to get it fixed. :)

Share This Page