Cache Problem On Backend of Joomla

vahid07

New Member
#1
Hi,

i enabled LSCache globally on my server (directadmin+openlitespeed). but theres problem with cache on backend of joomla site (joomla 3.10). on publish articles,save setting,login,logout... . all thing have problem according to new cache method because all page cached. so it seems first important thing is backend of joomla (https//www.domain.com/administrator/) not be cache. i try to add /administrator/ to exclude url in lscache component but it dont work. theres no any option to exclude users group (like wp plugin) or backend cache completly. so what can i do? please guide.

Thank you
 

vahid07

New Member
#3
i changed httpd-lscache.conf to this:

Code:
module cache {
    ls_enabled          1

    checkPrivateCache   1
    checkPublicCache    1
    maxCacheObjSize     10000000
    maxStaleAge         200
    qsCache             1
    reqCookieCache      1
    respCookieCache     1
    ignoreReqCacheCtrl  1
    ignoreRespCacheCtrl 0

    enableCache         0
    expireInSeconds     3600
    enablePrivateCache  0
    privateExpireInSeconds 3600

}
and install joomla plugin (and its enable with default) and insert this code in .htaccess of that:

Code:
<IfModule LiteSpeed>
CacheLookup on
</IfModule>
and the graceful restart the OLS. but i cant see lscache header in page and also result of https://check.lscache.io/ test is :LSCache is not supported

so whats the problem?!

** amazing issue is i installed wordpress in a new directory of my joomla site and then enable lscache form "directadmin LWS plugin" and it show lscache head !! result of https://check.lscache.io/ for it is :
LSCache is supported
LiteSpeed cache is a hit
 

Pong

Well-Known Member
Staff member
#4
a ticket asscicated with this issue and should have been fixed. OLS server level setting is correct( should not enable cache from server). Added virtual host level cache root/cache settings for better control. The Joomla plugin has incorrect settings to disable cache, clear these settings and cache works fine now.
 
Top