can't increase timeout

Discussion in 'Install/Configuration' started by marstall, Feb 1, 2007.

  1. marstall

    marstall Member

    i have a particular rails page that consistently takes awhile to generate (as it's supposed to), but no matter what i have tried i have been unable to tweak the timeout settings properly to avoid a 503 error. (running rails via lsapi, manual setup).

    When I run a webrick server in the same environment/directory, i can retrieve this file in around 66 seconds. However when i retrieve it via litespeed i consistently get a 503. I have maxed out the initTimeout and retryTimeout settings (to 6000) in http_config.xml (in tuning and also the extProcessor section) as well as the relevant vh_conf.xml.

    anything else i should try?

    cambridge ma
  2. mistwang

    mistwang LiteSpeed Staff

    You can try initTimeout = 300, retryTimeout should be 0.

    We tried a request with "sleep 65" at the begining of the controler code, it works.

    The 503 error may not all caused by the timeout, check if you Rails log, see if the request succeed or not. Also check stderror.log and error.log.

    Maybe you request need more memory to process, so increase the memory soft/hard limits may help.
  3. marstall

    marstall Member

    that was it - thanks

    mistwang - thanks for the prompt reply - i was in fact running out of memory. which led me to realize the page was implemented inefficiently, rewrote for a 10x speed/resources optimization and it's working good now.
  4. mistwang

    mistwang LiteSpeed Staff

    Thanks for the update. glad you figured it out.

Share This Page