Cant recompile PHP

Discussion in 'Install/Configuration' started by fastproxy, Jul 27, 2008.

  1. fastproxy

    fastproxy Well-Known Member


    I tried the compile php function in admin panel, configuration and compilation went fine but after restart. The PHP version and config is still the same as default although i added many options to configuration.

    Here is options that i compiled with PHP
    But PHP does not show what i compiled with.

    One thing i noticed though, one my other server. After the configuration my other server show litespeed use different php config path: /opt/lsws/lsphp4/lib/php.ini

    While one this server, PHP config still show default path: /opt/lsws/php/php.ini

    So what do i need to do?
    Last edited: Jul 29, 2008
  2. mistwang

    mistwang LiteSpeed Staff

    You need to change the configuration of lsphp4 or lsapiPHP external app to use $SERVER_ROOT/fcgi-bin/lsphp4
  3. fastproxy

    fastproxy Well-Known Member


    It works now. But i wonder why now i have to do it manually? Because before i installed LSWS many time on the same server and i did not have to change the PHP.ini path.

Share This Page