Clients not using Litespeed

Discussion in 'General' started by alexr, Mar 8, 2009.

  1. alexr

    alexr Member

    I just looked at your client page again and it appears that some of the large references you give actually don't use litespeed, atleast on their main page. A lot of the biggest ones (Twitter,, all return other webservers. Is this just lack of updates or have they used litespeed in the past or on other sites?

  2. anewday

    anewday Moderator

    Wordpress still uses litespeed, their load balancer runs on nginx. Does twitter use litespeed for its images only? Aquarius Storage switched back to Apache recently.
  3. anewday

    anewday Moderator

    Seems wordpress switched their http servers to nginx now. They only used nginx on their load balancers prior to this.

    The error pages no longer shows the default litespeed page.

    I'm more eager to see the updated benchmarks now, seems more and more are switching to nginx. :eek:
    Last edited: Apr 7, 2009
  4. Bono

    Bono Well-Known Member

    Nginx has very good support, everything is answered within minutes/hours while here after few weeks I didn't got any response. :mad:
  5. closet geek

    closet geek Well-Known Member

    I wouldn't get too excited. It's not like LS will publish benchmarks showing them losing to a rival product after all!
  6. auser

    auser Super Moderator

    can you share how to get Nginx support? forum, email, or chat? the support is from community users or from Nginx? A bit curious how a freeware can support so well. Thanks.
  7. Bono

    Bono Well-Known Member

    It already has very strong community so every problem is fixed really fast. You can check here .

  8. Lauren

    Lauren LiteSpeed Staff Staff Member

    nginx is a nice piece of software and free. Wordpress is using it for load balancer in front of lsws. It interprets the 404 pages.

    LiteSpeed supports .htaccess which is compatible with Apache, many wordpress users still reply on that.

  9. mistwang

    mistwang LiteSpeed Staff

    Are you kidding?
    I doubt those forum members have the capability of fixing bug in nginx.

    And I doubt the nginx developer himself has the time to answer your system administration question regarding basic Unix/Linux permission questions.

    If you looking for answers to generic Linux administration questions, you should go to forum like webhostingtalk or similar forum, larger community with more active members, your question is more likely get answered quickly.

    As a software vendor, our forum support is free and most time got answered quickly. If you want better turn-around time, there's premium support service available.
    Last edited: Apr 8, 2009
  10. Bono

    Bono Well-Known Member

    Like I said community not developer. So far support was provided via mailing list, and since forum is only 10 days old I'm sure it will pick up any time soon.

    And related to my problem if I needed support every day I would purchase premium support, but I had one problem and it was unanswered.

    Question was simple: can LSWS work same as apache, if it runs as nobody can it write files generated with web server as user defined in vhost.

    Like I said, normally I would use PHP suEXEC but it breaks Xcache.
  11. mistwang

    mistwang LiteSpeed Staff

    Everything follow Linux file system permissions, no web server can get around it.
    If your PHP run as nobody, it will create file as nobody, if it run as the user id defined in vhost, it will create file as that user.
    LiteSpeed has the option to setup the permission model exactly as Apache, whether to use PHP suEXEC, it is your call.
    We recommend using eaccelerator with /dev/shm as the cache disk storage.
  12. Bono

    Bono Well-Known Member

    Thanks, if you explained like that before I wouldn't have any complain about support. Thing is that apache2 worked as user nobody but generated files as vhost user1:user1 without defined user1:user1 in vhost. Since LSWS reads apache config I didn't touch it, I see in config there is now only variable suPHP because I ran it for few days.

    <IfModule mod_suphp.c>
    suPHP_UserGroup user1 user1

    Anyway I will try to make workaround that with

    Xcache works for me much better than Eaccelerator, only problem is while su php is enabled it doesn't work properly. :D

Share This Page