Compiling PHP with LiteSpeed: No rule to make target

Discussion in 'Install/Configuration' started by theRKF, Apr 17, 2012.

  1. theRKF

    theRKF Well-Known Member

    I'm trying to compile PHP with LiteSpeed for the first time on a new server, using the guideline at and using PHP 5.4.0.

    Here's the ./configure command:
    Once './configure' completes, I run 'make' and get this error:
    I have searched for a while and cannot find a solution for this problem. Has anyone run into this before?

    Any ideas on a solution?

    FYI: The web interface failed a number of times, so I opted for the command line install.
  2. webizen

    webizen Well-Known Member

    You should use the LSAPI that comes with PHP 5.4 source.
  3. theRKF

    theRKF Well-Known Member

    Ok, I'm sold on that idea ...

    Downloaded a fresh archive for php 5.4.0, ran configure, make.

    That worked. Not sure what was different this time around, versus the previous 4-5 attempts :)
  4. webizen

    webizen Well-Known Member

    Last edited: Apr 18, 2012
  5. theRKF

    theRKF Well-Known Member

    I just ran into this problem with 5.4 (and 5.5? can't remember if it happened on both). Earlier I was told to d/l the LSAPI from LiteSpeed to get the most current version. I think version 5.5 is the one shipping with PHP 5.4, but the newer LSAPI I downloaded produced this error.

    Should we just stick with the lower version of the API?
  6. NiteWave

    NiteWave Administrator

    any control panel(e.g.WHM/cPanel) installed on this server ?
  7. theRKF

    theRKF Well-Known Member

    cPanel installed
  8. NiteWave

    NiteWave Administrator

    for WHM/cPanel, the recommended way is: use EasyApache to build php(either the system is running litespeed or apache), then "Build Matching PHP" in WHM lsws plugin.

    php lsapi version will be selected automatically. current version is 6.3(the latest)
  9. theRKF

    theRKF Well-Known Member

    Wow, that's news to me. I've always been told to build through the LS control panel, and when that failed (constantly) or didn't support the latest PHP version I was told to build PHP via command line following the LS tutorial.

    We've had LS paid support set up our last two servers, and both times I'm certain they used command line. Is this perhaps because we're running multiple PHP versions?
  10. NiteWave

    NiteWave Administrator

    for best compatible with apache and convenient for most users, we recommend to run easyApache first + Build Matching PHP mechanism for WHM/cPanel users.

    this also applies for multiple php versions -- just repeat same steps one by one.

    however, build php through lsws admin console should be work too, especially for users without control panel. build php through command line is actually more complicated than using easyapache.
  11. theRKF

    theRKF Well-Known Member

    Ok, got it, thanks - but help me out ... how does this address the LSAPI issue?

    Does building through EasyApache + Build Matching get the latest LSAPI working, or are we stuck with v5.5?

  12. NiteWave

    NiteWave Administrator

    I think Build Matching PHP will result latest lsapi, at present it's 6.3

    please refer the release log:
    from lsapi 6.0, the major change is the new PHP suEXEC daemon mode

    5.5 is ok if you needn't this daemon mode and 5.5 has been working well.
    in general 6.3 is compatible with 5.5

    so I recommend to stick with 6.3, unless 6.3 has unusual compatible/stable issue for your usage in special cases, don't revert back to 5.5. and so far I haven't been aware any such special cases which must revert back to 5.5

Share This Page