Context with pcre strips first character?

Discussion in 'Bug Reports' started by fantasydreaming, Feb 10, 2011.

  1. fantasydreaming

    fantasydreaming Well-Known Member

    3 Contexts (#1 static, below, #2 dummy one b/c it wouldn't let me sort with jsut two - another bug?, #3 Rails). I've disabled rewrite in my virtual host for testing.

    Static context
    location: /public/$1
    Enable expires: Yes
    Expires Default: M180
    Enable Rewrite: No

    Requsted /login/get_online

    Log file shows:
    2011-02-10 10:15:05.055 INFO [] File not found [//ublic/login/get_online]
    2011-02-10 10:15:05.675 INFO [] File not found [//ublic/feature/box]
    2011-02-10 10:15:06.197 INFO [] File not found [//ublic/login/get_online]
  2. webizen

    webizen Well-Known Member

    Please provide your server environment info: LSWS version, OS version (32 bit or 64 bit), etc.
  3. fantasydreaming

    fantasydreaming Well-Known Member

    Mac. not sure whether 32 or 64. I tested the latest version and the one before it.
  4. mistwang

    mistwang LiteSpeed Staff

    Please try a force reinstall see if the problem is still there.
  5. fantasydreaming

    fantasydreaming Well-Known Member

    Forcing a reinstall seems to have fixed the missing-character problem. Strange!

    There's definitely a bug with the reordering of the contexts though. Frustrating trying to get them in a particular order. + sometimes moves up or down, and changing the order direction confuses things. Sometimes when I get it set and restart, the order isn't what I'd set.

    Also, it'd be nice to add a line to the log about which context is being used (perhaps the debug logging?). Right now I don't think there's anything. Debug statements about the PCRE tests would be handy too.

    2011-02-11 10:29:08.574 NOTICE Toggle debug logging request from admin interface!
    2011-02-11 10:29:11.905 NOTICE [] Content len: 0, Request line: 'GET /login/get_online HTTP/1.1'
    2011-02-11 10:29:11.905 INFO [] Cookie len: 461, cookies_removed
    2011-02-11 10:29:11.905 INFO [] File not found [/Users/inspire/Dropbox/newap/public/login/get_onlineBLAH]

    Even with debug logging, it seems my context never gets checked unless I disable my vhost rewrites (probably because they get rewritten to either 'Last' or dispatch.fcgi)

    Toggling debug logging on should send you to the 'browse server log' page, not back to the homepage.

    Thanks for a great project!
  6. fantasydreaming

    fantasydreaming Well-Known Member

    default mime type

    In the Context settings there's a handy 'set default mime type' option. Is this settable on a per-server basis as well?
  7. NiteWave

    NiteWave Administrator

    default mime type: can customize it at server level and can override it at vhost and in .htaccess.

Share This Page