did anyone manage to get trac to work with litespeed?

Discussion in 'Install/Configuration' started by ts77, Dec 6, 2005.

  1. ts77

    ts77 Well-Known Member

    Hi there,

    now that trac 0.9 supports a fcgi-interface I'm trying to run it through litespeed this way.

    Their documentation for that is on this page http://projects.edgewall.com/trac/wiki/TracFastCgi .

    I'm getting strange errors and I'm not sure if its litespeed-related or some general problem in trac or the python-fcgi libraries.

    The errors look like the following:

    Trac detected an internal error:

    not indexable
    Traceback (most recent call last):
    File "/usr/lib/python2.4/site-packages/trac/web/fcgi_frontend.py", line 40, in _handler
    dispatch_request(req.path_info, req, env)
    File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 139, in dispatch_request
    File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 84, in dispatch
    populate_hdf(req.hdf, self.env, req)
    File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 193, in populate_hdf
    for arg in [k for k in req.args.keys() if k]:
    File "/usr/lib/python2.4/cgi.py", line 601, in keys
    raise TypeError, "not indexable"
    TypeError: not indexable


    I tried it in two different ways ...
    once I created an fcgi-context pointing some specific url to the fcgi-app.
    another try was with a static context pointing to the cgi-bin directory and adding the .fcgi to the handler for the fcgi-app.

    any ideas or does that error ring a bell for someone?
  2. mistwang

    mistwang LiteSpeed Staff

    Finally figured it out, problem is in its FastCGI interface, it is very sensitive to the trailing '\0' in a FCGI environment variable which sent by LSWS in request method.

    Fix will be in 2.1.7.
  3. ts77

    ts77 Well-Known Member

    Thats great news. Thanks George.
    Let me know when I can test the 2.1.7 ... its only a dev-install there right now so I can play with it.
  4. mistwang

    mistwang LiteSpeed Staff

    2.1.7 is out, you can give it a try. :)
  5. ts77

    ts77 Well-Known Member

    Wow, its working great now. thanks.
  6. Dani

    Dani Well-Known Member

    [2005-12-09 22:14:29] Checking for new release...
    [2005-12-09 22:14:29] [OK] Package is uptodate.

    goto admin page:
    LiteSpeed/2.1.6 Standard

    nonfunctional update yet?
  7. ts77

    ts77 Well-Known Member

  8. Dani

    Dani Well-Known Member

    Yea know, just wondering if the autoupdate ever will function since I'm a fan of autoinstall/update procedures =)

    2005-12-09 22:14:28.140 NOTICE [Child: 26539] LiteSpeed/2.1.6 Standard starts successfully!
    2005-12-09 22:14:29.000 NOTICE [AutoUpdate] Checking for new releases...
    2005-12-09 22:14:29.296 INFO [AutoUpdate] No new update.
  9. mistwang

    mistwang LiteSpeed Staff

    New release has not been fed to our auto-update system yet. You can try it by a manul upgrade. If there is no bug report after a while, we will pull the trigger. :)
  10. ts77

    ts77 Well-Known Member

    it will "ever" function I guess but its common sense to wait some days for feedback from manual installs and after that update the autoupdate so that you don't run into too much trouble at once :).

    Edit: yep, just what mistwang said ;)
  11. Dani

    Dani Well-Known Member

    sounds great =) I'm gonna give it a test, you should really place a link with the changes of the new versions =) tried searching but didn't find one, maybe missed it..
  12. ts77

    ts77 Well-Known Member

  13. Dani

    Dani Well-Known Member

    hehe knew I missed it.

    * A bug that causes broken zipped dynamically generated pages in IE has been fixed.

    so my problem was found? =) Gonna try and see if it will work with dynamic set to on. Half of the fixes were my nags =) It's great when the developers are so close to the users and listen.

Share This Page