Error 406 After Upgrade to 4.0.1

Discussion in 'General' started by DraCoola, Apr 11, 2009.

  1. DraCoola

    DraCoola Well-Known Member

    After manual upgrade from 4.0 to 4.0.1, I have an error like bellow while execute domain search script :

    406 Not Acceptable

    This request is not acceptable
    Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!

    Switch to mod_suphp and the script just work fine.
    Downgrade to 4.0 again still got the same 406 error.
    Downgrade to 3.3.24 brought the same error either.
    That script has just worked fine before this v4.0.1.

    The error log from cpanel is :
    [] File not found [/home/dxxxxx/public_html/406.shtml]

    My external App environment is :

    Any idea how to fix this?
  2. DraCoola

    DraCoola Well-Known Member

    Update :

    SMF login are facing the same error page : 406 not acceptable
    All SMF user cannot login to their forum.

    Please help me....
  3. DraCoola

    DraCoola Well-Known Member

    Update 2 :

    Cannot switch to apache through lsws whm plugin after upgrade to 4.0.1.
    I have to start apache manually from console in purpose to switching.
  4. DraCoola

    DraCoola Well-Known Member

    Update 3 :

    1. Uninstall v4.0.1 through sh /usr/local/lsws/admin/misc/
    2. Remove lsws directory
    3. Installing v4.0 from scratch

    Problem solved :)
  5. mistwang

    mistwang LiteSpeed Staff

    I think 406 was the result of a mod_security rule.
    I could not think of any change in 4.0.1 that can cause this.
    maybe I can take a look at your server if you don't mind.
    And there is no need to reinstall from scratch, just use /usr/local/lsws/admin/misc/ to switch between versions, just make sure to restart LSWS after that.
  6. DraCoola

    DraCoola Well-Known Member

    I have switching between v3.3.24, v4.0, and v4.0.1 on the fly through lsws whm plugin but still resulting error 406 while executing login form on any sites under my server.

    But if I switch to apache + suphp, the problem is just dissapear.
    The mod_sec2 rules are the same for both apache or litespeed.

    I hope you can investigate this issue, check your PM.

    Thank you for helps :)
  7. DraCoola

    DraCoola Well-Known Member

    Solved by mistwang... 4.0.1 installed now without any problem. Cool!!
    Many of thank you :)
  8. anewday

    anewday Moderator

    What's the problem and solution?
  9. muiruri

    muiruri Well-Known Member

    I'm having the same problem in one of my servers

    I have tried many times to remove & re-install 4.0.2, but no luck.

    So temporary have restored back to 3.3.24

    How did George fix it?

  10. mistwang

    mistwang LiteSpeed Staff

    enable mod_security debug log from httpd.conf and check what happened in the error.log, must be a rule being triggered.

Share This Page