errors while using memcache under heavy load

Discussion in 'Ruby/Rails' started by cswilliams, Jan 24, 2007.

  1. cswilliams

    cswilliams Member

    I'm running httperf with the following settings:
    httperf --server localhost --uri /accounts/register --num-conn 5000 --num-call 10 --rate 200 --timeout 5

    Most pages work fine. I get a pretty high number of connection resets but I guess thats because my copy is limited to 300 connections?
    Anyway, when I run this on a page that uses memcache, it runs ok for awhile, then all of a sudden I start seing this in the stderr.log:
    fork() failed, please increase process limit: Resource temporarily unavailable
    Also this shows up many times as well:
    /lsws/fcgi-bin/RailsRunner.rb:11:in `accept': SIGUSR1 (SignalException)
    from /lsws/fcgi-bin/RailsRunner.rb:11

    I saw some other posts where it was suggested to increase the process limit, I increased it to 200 but this did not help.

    I must also mention this page loads fine if I go to it in a browser and seems to talk to memcache correctly as well.

    Any help would be appreciated.

  2. cswilliams

    cswilliams Member

    Ok, I got rid of the fork() errors by increasing the process limit by another 100. I still get several SIGUSR1 exceptions though. I tried taking some of the steps in the other posts that was suggested such as increasing the memory (i made it 1000M) and left the max idle time blank, however I still get the exceptions.
  3. mistwang

    mistwang LiteSpeed Staff

    Nothing to worry about the SIGUSR1, it either send by LSWS or the parent ruby process for various reasons, like LSWS restarts, all ruby processes started by it will be stoped. It should not affect normal Rails services in any way.

Share This Page